#28730 closed defect (not a bug)

Reduced availability of HS v3 services compared with that of v2

Reported by: jchevali Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-hs
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I serve sshd behind HS v2 and v3 services and I have done for a long time. I've used both alpha, beta, and release builds of Tor 0.3.4 and 0.3.5 for this.

Per my experience, HS v2 services are almost always available for the client to connect to, but HS v3 services not so much. There are periods in which the client can't connect to v3 services (high CPU at client for a minute, then give up), while for the corresponding v2 service the connection is almost instant.

Of course I would prefer to use v3 services if I can, if I observe they have the same degree of availability, but while I can't, I keep defining them in pairs (v3 + v2), because I know the time will come for some unspecified reason I can't use them (for hours at a time), and I want to keep for myself a workable alternative.

If I'm the only one to notice this, perhaps it's because I like to exclude lots of countries in ExcludeNodes, both at server and client side, and perhaps this affects v3 services only, or not only but disproportionally (and perhaps no one uses like this so they don't know). But that's the focus on my other ticket, #27811, and I won't postulate that here again.

For the moment I've got no solution, other than in my experience HS v3 services are less available therefore less dependable than v2 services.

Child Tickets

Change History (3)

comment:1 Changed 11 months ago by dgoulet

Right. We are aware that there are some hiccups with v3 while v2 is more stable meaning more reachable. We hope to be able to look at more long term reachability issues that v3 could be suffering soon.

Version 2 is not being deprecated just yet from the code but when we do, we'll make sure v3 is not only feature parity with v2 but as stable.

In the meantime, any info logs (ideally debug but it takes a lot of disk space) you can provide of a v3 service being in an unreachable state would be greatly useful to understand what is going on.

Thanks!

comment:2 Changed 11 months ago by dgoulet

Keywords: tor-hs added
Milestone: Tor: unspecified

comment:3 Changed 11 months ago by dgoulet

Component: Core TorCore Tor/Tor
Resolution: not a bug
Status: newclosed

No action items on this ticket. However, we are aware of the possible stability/reachability issue so it will be looked in for sure.

Note: See TracTickets for help on using tickets.