Opened 12 months ago

Closed 5 months ago

#28756 closed defect (wontfix)

Sync doesn't work with Tor Browser for Android

Reported by: dimqua Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile, tbb-crash
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm unable to use Firefox Sync functionality in the latest version (8.5a5) of Tor Browser for Android, since the app is constantly crashed when I trying to do so.

Child Tickets

Change History (5)

comment:1 Changed 12 months ago by gk

Keywords: tbb-mobile tbb-crash added
Status: newneeds_information

Do you have steps to reproduce those crashes? Sync is not really supported right now, but it should not crash.

comment:2 Changed 12 months ago by dimqua

  • Open Settings -> Homepage. Turn off Also use for new tabs option.
  • Open a new tab. And switch to History tab.
  • Click Synced devices, then Get started.
  • Crash!

comment:3 Changed 5 months ago by sysrqb

Resolution: duplicate
Status: needs_informationclosed

Thanks for reporting this. It should be fixed in #30086.

comment:4 Changed 5 months ago by sysrqb

Resolution: duplicate
Status: closedreopened

After chatting with gk, I agreed this ticket is not only about the app crashing but the intended goal is actually using Sync, as well. We did prevent the crash in #30086, but there are a few remaining problems we should fix before allowing Sync again.

In particular, we must solve #28125 and #27069. We must also decide if Firefox Accounts should be added as an Account on the Android device (related to #27069) or should Sync only be available as an in-app feature.

Currently, we completely exclude the Sync functionality when the app is built.

comment:5 Changed 5 months ago by sysrqb

Resolution: wontfix
Status: reopenedclosed

Unfortunately, this is a significant amount of work, and I doubt we will accomplish this within the next year. Mozilla are working on a new browser (Fenix), as well, where many of these problems should not exist (or hopefully we'll find them and fix them early).

I'm setting this as wontfix for now, because I don't think this is a ticket we can realistically fix due to the amount of time this would require and Mozilla's upcoming browser for Android.

Note: See TracTickets for help on using tickets.