Opened 4 months ago

Last modified 4 months ago

#28772 new defect

DNS resolver at DNSPort stops working after some time, while tor is working. Only restart helps.

Reported by: toruser787 Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.3.5.5-alpha
Severity: Normal Keywords: dns bug fail restart dnsport
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello. I am tor user more than 6 years. And always this problem existed. Now I am totally tired and decided to fill a bug. I am using always latest versions, now at 0.3.5.5 and on android the same, latest 0.3.* version.

I use DNSPort option and route all my DNS traffic to it. After tor is connected, it is working well, but after some time (2-5-10 hours), it stop to work and return no IP address to any DNS request, while the tor itself continue working, log don't show anything relevant. DNS requests resolve only internally through socks port.

This happens many years to me, and only restarting tor helps to get my DNS back.
I even tried to open multiple DNSresolvers, like
DNSPort 127.0.0.2:53
DNSPort 127.0.0.3:53
DNSPort 127.0.0.4:53

and put them all to /etc/resolv.conf, and it helped to keep it running more long, but anyway after some time they all stops resolving.

On android I have the same issue. I rerouted all DNS traffic to it, and after some hours only restarting to service works. I even thought to write some script, if domain fails to resolve, restart to service...

Please help! DNSPort resolver must recreate it's circuits if they fails. and don't wait for hard reset.
Thank you!

Child Tickets

Change History (4)

comment:1 Changed 4 months ago by teor

Milestone: Tor: unspecified
Priority: ImmediateMedium
Severity: BlockerNormal

comment:2 Changed 4 months ago by nickm

Can you double-check which is the first version that has this problem? It might help us track down the bug.

comment:3 Changed 4 months ago by toruser787

it started on some 0.2.x versions...

comment:4 Changed 4 months ago by nickm

I've tried to reproduce this, but it hasn't happened for me yet. I started a tor instance and left it running since Monday, but it still resolved a DNS address for me today, after days of unuse. I'm going to leave it alone for a week or so and see if that's long enough.

If it doesn't happen for me, some possibilities:

  • Maybe this only happens on Android?
  • Maybe there is some important difference between your torrc and mine?
Note: See TracTickets for help on using tickets.