Opened 8 years ago

Closed 3 years ago

#2879 closed enhancement (wontfix)

Add TBB packages to our repos

Reported by: mikeperry Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: Bounty, needs-triage
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by mikeperry)

We need to create distribution packages as a stopgap to solve the issue with Thandy not existing. We need some way to provide auto-update to people who are used to it, especially if we are making TBB the only package that we provide. This ticket is the parent ticket to enumerate all of the issues of converting the TBB tarballs into .dep and .rpms, using the shortest, simplest possible path (since eventually we want to abandon this method of distribution in favor of Thandy).


Child Tickets

Change History (17)

comment:1 Changed 8 years ago by mikeperry

Parent ID: #2880

comment:2 Changed 8 years ago by mikeperry

Description: modified (diff)

comment:3 Changed 8 years ago by ioerror

I think this is a great idea for people who have admin rights on their computer; for all others, I think we need a way for the TBB to know what version is current and it should alert the user when it isn't up to date.

comment:4 in reply to:  3 ; Changed 8 years ago by mikeperry

Replying to ioerror:

I think this is a great idea for people who have admin rights on their computer; for all others, I think we need a way for the TBB to know what version is current and it should alert the user when it isn't up to date.

Vidalia already has code to provide this message. I've seen it quite a few times. It is based on the consensus recommended versions.

(Also to your first point, I assume thandy can work without admin rights.)

comment:5 in reply to:  4 ; Changed 8 years ago by rransom

Replying to mikeperry:

Replying to ioerror:

I think this is a great idea for people who have admin rights on their computer; for all others, I think we need a way for the TBB to know what version is current and it should alert the user when it isn't up to date.

Vidalia already has code to provide this message. I've seen it quite a few times. It is based on the consensus recommended versions.

That is for outdated versions of Tor only. It does not warn about outdated versions of TBB or its other components.

The only way to inform users of current versions of TBB that a newer version has been released is to list the versions of Tor packages on check.torproject.org. See #2285.

comment:6 in reply to:  5 ; Changed 8 years ago by mikeperry

Replying to rransom:

Vidalia already has code to provide this message. I've seen it quite a few times. It is based on the consensus recommended versions.

That is for outdated versions of Tor only. It does not warn about outdated versions of TBB or its other components.

The only way to inform users of current versions of TBB that a newer version has been released is to list the versions of Tor packages on check.torproject.org. See #2285.

Doh. I hadn't even though of this. The huge, self-contained dependency structure of TBB is going to require something more than #2285.

We could pass a version to check.tp.o, since it is the home page of TBB. Then the verbage on check.tp.o can still remain concise, perhaps simply displaying an orange onion if your version is out of date...

comment:7 in reply to:  6 Changed 8 years ago by mikeperry

Replying to [comment:6 mikeperry

Doh. I hadn't even though of this. The huge, self-contained dependency structure of TBB is going to require something more than #2285.

And by more than #2285, I think we can instead re-purpose #2285 to provide us with the notification we need in the short-term.

comment:8 in reply to:  6 Changed 8 years ago by rransom

Replying to mikeperry:

Replying to rransom:

Vidalia already has code to provide this message. I've seen it quite a few times. It is based on the consensus recommended versions.

That is for outdated versions of Tor only. It does not warn about outdated versions of TBB or its other components.

The only way to inform users of current versions of TBB that a newer version has been released is to list the versions of Tor packages on check.torproject.org. See #2285.

Doh. I hadn't even though of this. The huge, self-contained dependency structure of TBB is going to require something more than #2285.

No -- just treat TBB as a single package for the purpose of that list.

We could pass a version to check.tp.o, since it is the home page of TBB. Then the verbage on check.tp.o can still remain concise, perhaps simply displaying an orange onion if your version is out of date...

That won't work for users of existing TBBs, and it gives check.tpo the ability to log more detailed information about users. We don't want to give whoever controls the check.torproject.org domain name and can get an SSL certificate for it that Firefox will accept the ability to collect that information.

comment:9 Changed 8 years ago by mikeperry

Type: defectenhancement

comment:10 Changed 8 years ago by mikeperry

Keywords: Bounty added

comment:11 Changed 8 years ago by mikeperry

Parent ID: #2880

comment:12 Changed 7 years ago by erinn

Owner: erinn deleted
Status: newassigned

Unassigning this from myself. Someone else should feel free to take it.

comment:13 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:14 Changed 5 years ago by erinn

Component: Tor bundles/installationTor Browser

comment:15 Changed 4 years ago by proper

Severity: Normal

Duplicate of #5236? (Contains more discussion.)

(Except #5236 is for deb only. And this one is for deb and rpm. I suggest to make this a duplicate of #5236 and to create a new ticket for rpm if desired.)

comment:16 Changed 3 years ago by arma

I agree -- I think this ticket is now obsolete with Tor Browser's secure update feature.

comment:17 Changed 3 years ago by gk

Resolution: wontfix
Status: assignedclosed

Indeed.

Note: See TracTickets for help on using tickets.