Opened 7 months ago

Closed 7 months ago

#28790 closed defect (duplicate)

Webpage size shouldn’t depend on browser chrome

Reported by: dante01123 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor Browser 8.0.3 (64 bits, Windows 10) has a default window size of 1002 × 995 pixels.

When enabling the Bookmarks Toolbar (i.e. making it always visible), the browser window stays the same size, thus reducing the size of the webpage (and helping fingerprinting).

This also happens with the Menu Toolbar (and is arguably worse for fingerprinting, because the resize happens interactively on keypress, e.g. Alt + F) and the Bookmarks sidebar.

To keep the webpages the same size for all the users, I propose that enabling toolbars and sidebars also extend the size of the browser window by an appropriate amount.

Child Tickets

Change History (2)

comment:1 Changed 7 months ago by Thorin

changing theme density, sidebar, menubar, findbar (and even padding of icons on the toolbar) = any change to chrome after opening will not automatically resize the browser to control the inner window dimensions.

Tor Uplift will instead control the viewport: https://bugzilla.mozilla.org/show_bug.cgi?id=1407366 and this should be in the next ESR (fingers crossed)

comment:2 in reply to:  1 Changed 7 months ago by gk

Resolution: duplicate
Status: newclosed

Replying to Thorin:

changing theme density, sidebar, menubar, findbar (and even padding of icons on the toolbar) = any change to chrome after opening will not automatically resize the browser to control the inner window dimensions.

Tor Uplift will instead control the viewport: https://bugzilla.mozilla.org/show_bug.cgi?id=1407366 and this should be in the next ESR (fingers crossed)

Yes, which is essentially some variation of #14429. Closing this ticket as a duplicate of the former.

Note: See TracTickets for help on using tickets.