Opened 5 months ago

Closed 5 months ago

#28791 closed defect (duplicate)

Tor Browser 8 cannot download images protected by basic auth

Reported by: pf.team Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-linkability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TB seems to ignore authentication credentials when trying to download images from .onion sites protected by basic http authorization. The "Authorization: Basic" header is missing, and the site returns 401 Authorization Required.

To reproduce this error:

1) Setup an nginx server with some test dummy config and some login:password pair generated by openssl passwd in htpasswd:

root /var/www/html;

server_name _;
location / {

auth_basic "closed site";
auth_basic_user_file htpasswd;

}

2) Put a test .png or .jpg file into /var/www/html
3) Try to access the file at http://<domain-name>.onion/test.png
4) Enter login and password when prompted - check that the file displays properly.
5) Now try to download the file (Ctrl+S) and get a 401 error.

If the server doesn't provide a text response for the 401 error, TB will simply create an empty file.

Child Tickets

Change History (3)

comment:1 Changed 5 months ago by gk

Keywords: tbb-linkability added; TorBrowser files download auth removed
Status: newneeds_information

Which Tor Browser version are you using? If it's not the latest alpha, please try that one (https://www.torproject.org/projects/torbrowser.html.en#downloads-alpha). We recently landed a fix for #22343 which might make things work for you.

comment:2 Changed 5 months ago by pf.team

8.0.4 was used. In latest alpha (8.5a6) image downloaded properly.

comment:3 Changed 5 months ago by gk

Resolution: duplicate
Status: needs_informationclosed

Thanks, closing this as a duplicate of #22343 then.

Note: See TracTickets for help on using tickets.