Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#28857 closed defect (duplicate)

A commit has broken creation of v3 onion services with Stem 1.7

Reported by: maqp Owned by: atagar
Priority: High Milestone:
Component: Archived/Stem Version:
Severity: Normal Keywords: regression hs
Cc: atagar Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The commit in question is this. The previous commit works.

Bash script to reproduce the bug on Ubuntu 18.10 can be found here.

Child Tickets

Change History (7)

comment:1 Changed 18 months ago by nickm

Component: - Select a componentCore Tor/Tor
Keywords: regression hs added
Milestone: Tor: 0.4.0.x-final

comment:2 Changed 18 months ago by maqp

This bug affects both OnionShare and TFC that are no longer able to use v3 Onion Services. For TFC it makes releasing the next version quite impossible as it will be v3 only.

Does Tor 0.4.0.x-final milestone mean the projects will have to wait until April? Everything has been working great for five months: ever since #25552 (that was considered to be 0.3.5 must) was fixed.

I understand you're busy but if it's at all possible, could you please take a look what's going on.

Atagar: can you please check if this is something Stem could fix?

comment:3 Changed 18 months ago by nickm

Milestone: Tor: 0.4.0.x-finalTor: 0.3.5.x-final

Oh; I hadn't seen that this bug is in 0.3.5.

I don't see how it can be caused by the commit that you mention, though: that commit only changes log messages.

comment:4 Changed 18 months ago by nickm

Cc: atagar added
Component: Core Tor/TorCore Tor/Stem
Milestone: Tor: 0.3.5.x-final
Owner: set to atagar

Oh, I get it! This is the stem bug related to the changed log messages. It should be fixed in stem soon.

comment:5 Changed 18 months ago by maqp

nickm: Thank you! I'm not sure to what bug you are referring to. Is there a ticket number?

comment:6 in reply to:  5 Changed 18 months ago by dgoulet

Replying to maqp:

nickm: Thank you! I'm not sure to what bug you are referring to. Is there a ticket number?

#28844

comment:7 Changed 18 months ago by atagar

Resolution: duplicate
Status: newclosed

Hi Nick. To be clear this was *not* a stem bug. Stem was working as intended.

Tor changed its bootstrap log messages with the upfront understanding that it would break things like this. Please see #28731 for the discussion.

Last edited 18 months ago by atagar (previous) (diff)
Note: See TracTickets for help on using tickets.