Opened 5 months ago

Closed 11 days ago

#28909 closed defect (not a bug)

jenkins stem ci jobs are missing some dependencies

Reported by: teor Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Stem Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Do the stem CI jobs on jenkins need these missing dependencies to run the full suite of tests?

stem-ci-linux and stem-tor-ci are missing cryptography, pynacl, and pycodestyle:

18:52:27   stem version...                                      1.7.0-dev
18:52:27   python version...                                    2.7.9
18:52:27   operating system version...                          Linux (debian 8.11)
18:52:27   cryptography version...                              missing
18:52:27   pynacl version...                                    missing
18:52:27   mock version...                                      1.0.1
18:52:27   pyflakes version...                                  0.8.1
18:52:27   pycodestyle version...                               missing
18:52:27   checking for orphaned .pyc files...                  done (0.0s)
18:52:27   checking for unused tests...                         done (0.0s)
18:52:27   importing test modules...                            done (0.2s)
18:52:27   running pyflakes...                                  running
18:52:27   running pycodestyle...                               unavailable

https://jenkins.torproject.org/job/stem-ci-linux/lastBuild/ARCHITECTURE=amd64,SUITE=jessie/console

And similar output for:
https://jenkins.torproject.org/job/stem-tor-ci/lastBuild/console

Child Tickets

Change History (2)

comment:1 Changed 5 months ago by atagar

Hi teor. Nope, you don't need any of these but in this case I'd advise installing cryptography...

  • When cryptography is installed stem has additional capabilities such as the ability to validate descriptor signatures and communicate with tor's ORPort. The later is a useful exercise of the tor binary.
  • When pynacl is installed stem has ed25519 validation capabilities, but are not necessary for our integ tests of tor.
  • pycodestyle and pyflakes provides stem's static analysis checks. Like unit tests these are irrelevant to core tor changes.

comment:2 Changed 11 days ago by atagar

Resolution: not a bug
Status: newclosed

Hi teor, feel free to reopen if you need anything else.

Note: See TracTickets for help on using tickets.