Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#28910 closed defect (worksforme)

stem's jenkins CI runs the stem unit tests and the tor tests

Reported by: teor Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Stem Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: #28568 Points:
Reviewer: Sponsor:

Description

Hi atagar,

Does your advice about using --integ:
https://trac.torproject.org/projects/tor/ticket/28552#comment:4

Apply to the jenkins stem-tor-ci job?

It's currently using --all --target RUN_ALL:

timeout -k 5m 60m python ./run_tests.py --all --tor ./RESULT/tor --target RUN_ALL --log NOTICE

https://jenkins.torproject.org/job/stem-tor-ci/lastBuild/console

Child Tickets

Change History (1)

comment:1 Changed 12 months ago by atagar

Resolution: worksforme
Status: newclosed

Hi teor, No, stem-tor-ci is the jenkins test that notifies me of stem regression and compatibility issues with tor. Since that job is intended to catch my mistakes the unit test output is useful.

Last edited 12 months ago by atagar (previous) (diff)
Note: See TracTickets for help on using tickets.