Opened 5 months ago

Closed 4 months ago

Last modified 4 months ago

#28988 closed defect (duplicate)

Bridge node wil be exposed by malicious middle nodes.

Reported by: TBD.Chen Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.5.3-alpha
Severity: Normal Keywords: Bridge
Cc: Actual Points:
Parent ID: #7144 Points:
Reviewer: Sponsor:

Description

If a TCP stream from a bridge traverses malicious Tor middle routers, the bridge will be exposed.Why the client of bridge do not use Vangards? that pin the middle nodes into a small set.

Child Tickets

Change History (2)

comment:1 Changed 4 months ago by teor

Parent ID: #7144
Resolution: duplicate
Status: newclosed

Hi, this looks like a duplicate of #7144.

If a bridge needs privacy, it needs to make sure it uses a bridge guard. Expecting clients to keep a small number of middle nodes is not enough, because malicious clients won't do that.

comment:2 in reply to:  1 Changed 4 months ago by TBD.Chen

Expecting clients to keep a small number of middle nodes is not enough, because malicious clients won't do that.

If the attacker is the Client, then before she connect to the bridge, she have already nown the IP address of the bridge, and she do not need to expose the bridge to the other middle node.
However, if the attacker is the Middle node, then the innocent client keep a small number of middle nodes may effectively evade the malicous Middle node.

This is based the assumption that the attacker only want to collect the IP of bridge , and she never want to help the other attacker.

Note: See TracTickets for help on using tickets.