Opened 8 years ago

Closed 4 years ago

#2902 closed defect (wontfix)

Polipo conflicts with smart referer spoofing

Reported by: gk Owned by:
Priority: Medium Milestone:
Component: Polipo Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am not sure whether this really is a Torbutton bug but it seems at least not obvious to the user that Polipo prevents Torbutton's smart referer spoofing. We have implemented a test for it in our anon test.

Steps to reproduce:

1) Use Torbutton with Polipo activated (that's the default option in Torbutton as far as I can see) and check the referer functionality on http://ip-check.info. You'll see a orange field in the row with the referer check results and a warning.
2) Use Torbutton with Polipo deactivated and run the same anon test. You'll get a green field and the message that your smart referer spoofing works as expected.

Reproducible: always

Expected results: The smart referer spoofing should work always if it is selected as the user's choice of referer spoofing.

Child Tickets

Change History (4)

comment:1 Changed 8 years ago by mikeperry

Component: TorbuttonPolipo

Ahhhh. This is probably why the TAILS people hit #2148!

At any rate, we are planning to kill Polipo: #2844.

I've moved this bug to the Polipo component, where phobos will probably just close it, since nobody is fixing polipo bugs anyways.

comment:2 Changed 8 years ago by mikeperry

Owner: mikeperry deleted
Status: newassigned

comment:3 Changed 8 years ago by phobos

Resolution: wontfix

Polipo bugs should be opened at http://sourceforge.net/projects/polipo/

comment:4 Changed 4 years ago by arma

Severity: Normal
Status: assignedclosed
Note: See TracTickets for help on using tickets.