Opened 8 months ago

Closed 8 months ago

#29025 closed defect (duplicate)

OpenSSL will not compile without engine support

Reported by: Mangix Owned by:
Priority: Medium Milestone:
Component: Core Tor Version: Tor: unspecified
Severity: Normal Keywords: openssl, engine
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In OpenWrt, ENGINE support is disabled (supposed to be actually) and this makes compilation fail as currently in Tor, it is unconditionally disabled for ANDROID.

This changes tor to check for OPENSSL_NO_ENGINE which also works with Android.

The missing headers are for fixing offsetof and SHA512 being undefined.

Child Tickets

Attachments (1)

010-openssl-engines.patch (1.0 KB) - added by Mangix 8 months ago.

Download all attachments as: .zip

Change History (2)

Changed 8 months ago by Mangix

Attachment: 010-openssl-engines.patch added

comment:1 Changed 8 months ago by ahf

Resolution: duplicate
Status: newclosed

This is a duplicate of #29026

Note: See TracTickets for help on using tickets.