Opened 8 months ago

Last modified 5 months ago

#29032 new defect

Tor Browser 8.0.4 stops working correctly in Virtualbox on Windows

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Starting with https://blog.torproject.org/comment/278874#comment-278874 we got some feedback that text on some websites is not working properly starting with 8.0.4 on Windows once Tor Browser is run inside Virtualbox.

8.5a3 is the first alpha release that shows this behavior (https://blog.torproject.org/comment/279184#comment-279184) although it's not obvious how this is related as none of the 8.5a3 changes made it into 8.0.4 it seems.

I did not try to reproduce the issue yet.

Child Tickets

Attachments (1)

onmi804-vs-803.png (66.0 KB) - added by Thorin 5 months ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 8 months ago by gk

Keywords: tbb-regression added

Changed 5 months ago by Thorin

Attachment: onmi804-vs-803.png added

comment:2 Changed 5 months ago by Thorin

following from gk's comment, https://blog.torproject.org/comment/280752#comment-280752

I unpacked the 11mb sized omni.ja's from windows 64 bit en-US and compared the directories, the following are the only files that changed size changed content. If you want, I can run a hash check on all files and out the results. Otherwise the attached pic shows 14 files for you to think about

FWIW, I run VMs of 4 Linux and 2 Windows (on Windows 7 64bit) in VirtualBox 6.0 and have never seen OPs issue.

I wonder what Werner's VirtualBox release is?

Last edited 5 months ago by Thorin (previous) (diff)
Note: See TracTickets for help on using tickets.