Opened 3 months ago

Closed 3 months ago

#29126 closed defect (duplicate)

Connection error with Debian Tor 0.3.5.7-1 and Tor Socks5 proxy

Reported by: lanius Owned by: phoul
Priority: Medium Milestone:
Component: Community/Tor Support Version: Tor: 0.3.5.7
Severity: Normal Keywords: regression?
Cc: dgoulet, rl1987, ggus Actual Points:
Parent ID: #29050 Points:
Reviewer: Sponsor:

Description

I'm using a Tor proxy in my private LAN 192.168.1.0/24 on port 9050. That works fine with e.g. Telegram messenger in home zone to hide domestic DSL IP number. (Data stream is already encrypted)

Since update there are no longer connections possible. /var/log/tor/* shows what went wrong. There are lots of same entries:

Jan 18 18:55:15.000 [warn] socks5: parsing failed - invalid user/pass authentication message.
Jan 18 18:55:15.000 [warn] Fetching socks handshake failed. Closing.

If I set random login credentials (user/pass) in Telegram then Tor proxy works. A password isn't required but without an arbitrary username Tor connection failed again.

I never used Socks5ProxyUsername and Socks5ProxyUsername. Both are not set.

The Socks5 proxy setting in /etc/tor/torrc are:

SocksPort 127.0.0.1:9050
SocksPort 192.168.1.16:9050

My workaround is to set an arbitrary username and no password.

Hope that helps.


Child Tickets

Change History (1)

comment:1 Changed 3 months ago by rl1987

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.