Opened 7 weeks ago

Last modified 10 days ago

#29184 new enhancement

Avoid giving out bridges that suffer from #28912

Reported by: arma Owned by: sysrqb
Priority: Medium Milestone:
Component: Obfuscation/BridgeDB Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor19

Description

Bridges running 0.3.4.x before 0.3.4.10 suffer from #28912, where you basically can't bootstrap from them unless they have other people fetching directory information from them at the same time as you try. Same with 0.3.5.x before 0.3.5.7 I think.

Now that 0.3.4.10 is out, and 0.3.5.7 are out, hopefully bridges will upgrade. But for the ones that don't, we might be wise in bridgedb to decline to give them out.

I wonder what fraction of bridges this affects currently? I cc irl and karsten to find out.

Child Tickets

Attachments (1)

broken-bridges-2019-01-28.png (56.5 KB) - added by karsten 7 weeks ago.

Download all attachments as: .zip

Change History (5)

Changed 7 weeks ago by karsten

comment:1 Changed 7 weeks ago by karsten

Cc: metrics-team added


comment:2 Changed 7 weeks ago by arma

Beautiful. I think we are ready to implement this ticket any time then.

comment:3 Changed 7 weeks ago by gaba

Cc: irl karsten metrics-team removed

comment:4 Changed 10 days ago by arma

Sponsor: Sponsor19

marking as a sponsor19 ticket, because it should be easy to do and would be a big win for users

Note: See TracTickets for help on using tickets.