Opened 9 months ago

Closed 3 weeks ago

#29187 closed defect (fixed)

Bump NSIS version to 3.04

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: GeorgKoppen201901, tbb-rbm, TorBrowserTeam201909R
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A new NSIS version is out, 3.04 and we should switch to that one for creating our Windows installers.

Child Tickets

Change History (12)

comment:1 Changed 9 months ago by gk

Keywords: TorBrowserTeam201901R added; TorBrowserTeam201901 removed
Status: newneeds_review

bug_29187 (https://gitweb.torproject.org/user/gk/tor-browser-build.git/commit/?h=bug_29187&id=8c79a97d86183c3d69f97a72338e5b515c1649d4) in my public repo has the fix. However, we should figure out what is going on in #29185 first in order to be sure 3.04 is not introducing new reproducibility issues.

comment:2 Changed 9 months ago by langpack

no-insert-timestamp.patch?

comment:3 Changed 9 months ago by gk

Keywords: TorBrowserTeam201902R added; TorBrowserTeam201901R removed

Moving our review tickets to February.

comment:4 Changed 8 months ago by gk

Keywords: TorBrowserTeam201903R added; TorBrowserTeam201902R removed

February is gone.

comment:5 Changed 7 months ago by gk

Keywords: TorBrowserTeam201904R added; TorBrowserTeam201903R removed

Moving review tickets to April.

comment:6 Changed 6 months ago by gk

Keywords: TorBrowserTeam201905R added; TorBrowserTeam201904R removed

No April anymore, moving review tickets to May.

comment:7 Changed 5 months ago by gk

Keywords: TorBrowserTeam201906R added; TorBrowserTeam201905R removed

Moving reviews over to June.

comment:8 Changed 4 months ago by gk

Keywords: TorBrowserTeam201907R added; TorBrowserTeam201906R removed

No reviews in June 2019 anymore, moving them.

comment:9 Changed 3 months ago by gk

Keywords: TorBrowserTeam201908R added; TorBrowserTeam201907R removed

No July any longer.

comment:10 Changed 6 weeks ago by gk

Keywords: TorBrowserTeam201909R added; TorBrowserTeam201908R removed

No August anymore.

comment:11 in reply to:  1 ; Changed 3 weeks ago by boklm

Replying to gk:

bug_29187 (https://gitweb.torproject.org/user/gk/tor-browser-build.git/commit/?h=bug_29187&id=8c79a97d86183c3d69f97a72338e5b515c1649d4) in my public repo has the fix. However, we should figure out what is going on in #29185 first in order to be sure 3.04 is not introducing new reproducibility issues.

I started two builds on two machines with this patch on top of master, to check if the build is still reproducible with this version of NSIS.

comment:12 in reply to:  11 Changed 3 weeks ago by boklm

Resolution: fixed
Status: needs_reviewclosed

Replying to boklm:

Replying to gk:

bug_29187 (https://gitweb.torproject.org/user/gk/tor-browser-build.git/commit/?h=bug_29187&id=8c79a97d86183c3d69f97a72338e5b515c1649d4) in my public repo has the fix. However, we should figure out what is going on in #29185 first in order to be sure 3.04 is not introducing new reproducibility issues.

I started two builds on two machines with this patch on top of master, to check if the build is still reproducible with this version of NSIS.

In a first test I had matching i686 builds, but non matching x86_64, but it was probably caused by using different commits as the builds were not started exactly at the same time. On a second test, I now have x86_64 matching builds too. So this looks good to me.

I cherry-picked the patch as commit 936f5d7ad170e4d0dddc141906f006a6273196c8 on master.

Note: See TracTickets for help on using tickets.