#29193 closed defect (fixed)

obfs4 needs golang.org/x/net/http2

Reported by: boklm Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201901R, tbb-rbm
Cc: dcf, yawning Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The nightly build from today fails to build obfs4 with the following error:

/var/tmp/dist/gopath/src/gitlab.com/yawning/obfs4.git/transports/meeklite/transport.go:31:2: cannot find package "golang.org/x/net/http2" in any of:
        /var/tmp/dist/go/src/golang.org/x/net/http2 (from $GOROOT)
        /var/tmp/dist/gopath/src/golang.org/x/net/http2 (from $GOPATH)

I am not sure why the previous build did not fail. This might be related to the changes from #29178.

Child Tickets

Change History (5)

comment:1 Changed 10 months ago by yawning

The correct way to fix all of these issues permanently is #28325.

The go.mod and go.sum files in the repository specify all dependencies used (at the repository level), the exact versions, and a cryptographic digest of said dependency check-out.

https://github.com/golang/go/wiki/Modules#should-i-commit-my-gosum-file-as-well-as-my-gomod-file
https://tip.golang.org/cmd/go/#hdr-Module_downloading_and_verification

comment:2 Changed 10 months ago by boklm

Keywords: TorBrowserTeam201901R added; TorBrowserTeam201901 removed
Status: newneeds_review

So this build issue is caused by #29178. We were using the master commit of golang.org/x/net, but switched back to an older commit which doesn't provide golang.org/x/net/http2. Updating the goxnet commit to the one listed in go.mod is fixing the issue:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_29193_v2&id=1a03b88099512b3ccafc6c9b98641ffdb4a80d5d

comment:3 Changed 10 months ago by gk

Keywords: TorBrowserTeam201901 added; TorBrowserTeam201901R removed
Status: needs_reviewneeds_revision

Could you add a comment and point e.g. to this bug? Otherwise we might easily forget why we pinned that specific comment for the nightlies.

comment:4 Changed 10 months ago by boklm

Keywords: TorBrowserTeam201901R tbb-rbm added; TorBrowserTeam201901 removed
Status: needs_revisionneeds_review

comment:5 Changed 10 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good to me. Merged to master (commit 23f8101525288ccdd6ccef2035a698c4e9f1b232).

Note: See TracTickets for help on using tickets.