Opened 8 months ago

Closed 8 months ago

#29239 closed defect (fixed)

TBA: Don't ship torbutton xpi

Reported by: sysrqb Owned by: gk
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-torbutton, tbb-mobile, TBA-a3, TorBrowserTeam201901R
Cc: igt0 Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

During the packaging stage, we bundle torbutton@torproject.org.xpi, but it's already being included in chrome. We can probably save some bytes in the resulting apk.

 1:43.95 16559236 assets/features/torbutton@torproject.org.xpi (OK)
$ ls obj-x86-linux-android/dist/fennec/features/
torbutton@torproject.org.xpi

I think this is caused by the following in torbutton's moz.build:

FINAL_TARGET_FILES.features['torbutton@torproject.org'] += [
    'src/install.rdf'

]

Child Tickets

Change History (7)

comment:1 Changed 8 months ago by gk

Keywords: TBA-a3 TorBrowserTeam201901 added

comment:2 Changed 8 months ago by gk

Keywords: tbb-mobile added

comment:3 Changed 8 months ago by gk

Cc: igt0 added
Status: newneeds_information

I guess we can just remove those lines and are done?

comment:4 Changed 8 months ago by gk

Keywords: TorBrowserTeam201901R added; TorBrowserTeam201901 removed
Owner: changed from tbb-team to gk
Status: needs_informationassigned

comment:5 Changed 8 months ago by gk

Status: assignedneeds_review

comment:6 Changed 8 months ago by igt0

r=igt0. it also works in my test device.

comment:7 Changed 8 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Thanks! Merged to master (commit 70035640b586301baa4eebff868460c1e939b8e3).

Note: See TracTickets for help on using tickets.