#29240 closed enhancement (implemented)

if not present already, consider linking libzstd.so in Debian LTS builds

Reported by: starlight Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.3.5.7
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

atagar indicated in another ticket #29186 that Zstandard compression is not widely deployed. Perhaps the imminent LTS release of 0.3.5 should reference the shared library or statically link it.

Child Tickets

Change History (2)

comment:1 Changed 10 months ago by nickm

Could you open a debian ticket for this instead, and close this one? This team doesn't make the debian package.

comment:2 Changed 10 months ago by starlight

Resolution: implemented
Status: newclosed

Started working on submitting a ticket and found they have already included libzstd, so is done. Shows up as a package dependency here:

https://packages.debian.org/sid/tor

Note: See TracTickets for help on using tickets.