Opened 4 months ago

Closed 3 months ago

#29248 closed defect (duplicate)

Glitches in GUI after update process on win32.

Reported by: Crissy Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-update
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

After second process of update TorBrowser, there are visible glitches if the hardware acceleration is enabled. It can be observed in tab bar and in Discord web application.

Update from 6.04 to 6.05 Version.

Possibility not all required files are changed by installer.

Please see images.

Version before update: 8.0.4 (based on Mozilla Firefox 60.4.0esr) (32-bit)
Version after update: 8.0.5 (based on Mozilla Firefox 60.5.0esr) (32-bit)

Child Tickets

Attachments (3)

test1.jpg (18.8 KB) - added by Crissy 4 months ago.
test2.jpg (103.1 KB) - added by Crissy 4 months ago.
test3.jpg (149.3 KB) - added by Crissy 4 months ago.
Acceleration disabling

Download all attachments as: .zip

Change History (10)

Changed 4 months ago by Crissy

Attachment: test1.jpg added

Changed 4 months ago by Crissy

Attachment: test2.jpg added

comment:1 in reply to:  description Changed 4 months ago by gk

Status: newneeds_information

Replying to Crissy:

After second process of update TorBrowser, there are visible glitches if the hardware acceleration is enabled. It can be observed in tab bar and in Discord web application.

You mean those glitches are not visible if hardware acceleration is not enabled? How did you toggle that?

Changed 4 months ago by Crissy

Attachment: test3.jpg added

Acceleration disabling

comment:2 Changed 4 months ago by Crissy

These glitches was not visible if hardware acceleration disabled, but without acceleration the performance is very bad.

First time I have glitches after updating Tor Browser based on Firefox 52.x to 60.x.
The re-installation solved this problem.

Second - today. Also disabled acceleration helped. Looks like any library for hardware acceleration not changed or wrongly configured after update process. I enabled hardware acceleration, deleted Tor and TorBrowser and then installed TorBrowser. It helped. But it means: update process is defective.

How did you toggle that?

Please see test3.jpg file.

Last edited 4 months ago by Crissy (previous) (diff)

comment:3 Changed 4 months ago by Crissy

Status: needs_informationassigned

comment:4 in reply to:  2 Changed 4 months ago by gk

Cc: mcs brade added; tbb-team removed
Keywords: tbb-update added
Status: assignedneeds_information

Replying to Crissy:

These glitches was not visible if hardware acceleration disabled, but without acceleration the performance is very bad.

First time I have glitches after updating Tor Browser based on Firefox 52.x to 60.x.
The re-installation solved this problem.

Second - today. Also disabled acceleration helped. Looks like any library for hardware acceleration not changed or wrongly configured after update process. I enabled hardware acceleration, deleted Tor and TorBrowser and then installed TorBrowser. It helped. But it means: update process is defective.

How did you toggle that?

Please see test3.jpg file.

Thanks, that's really helpful. Is that issue reproducible on your system if you use an older Tor Browser, say 8.0.4, and update it? (see: https://archive.torproject.org/tor-package-archive/torbrowser/8.0.4/ for bundles) If so, how? Do you just need to update or do you need to have tabs open and update? Or...?

comment:5 Changed 4 months ago by gk

#28482 could be related.

comment:6 Changed 3 months ago by Crissy

Status: needs_informationassigned

I have no more information about it. I removed 8.0.4 completely with use of Shift+Del function of OS.

#28482 could be related.

I also saw reversed images. It is also visible in tab bar. Please see images. But not only images. I also saw identical effect like #28482. Removing the TB installation and reinstallation helped me. It is a TB Update problem.

Last edited 3 months ago by Crissy (previous) (diff)

comment:7 Changed 3 months ago by gk

Resolution: duplicate
Status: assignedclosed

Okay, let's move this over to #28482 then.

Note: See TracTickets for help on using tickets.