Opened 7 months ago

Closed 3 months ago

#29283 closed task (duplicate)

Make PTs go dormant

Reported by: cohosh Owned by:
Priority: Medium Milestone:
Component: Circumvention/Pluggable transport Version:
Severity: Normal Keywords: network-team-roadmap-2019-Q1Q2
Cc: cohosh Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor28-must

Description

This is to make PTs more friendly in mobile environments. Right now the PT process(es) keep running in the background when they are not being used, possibly making network connections.

We need to first figure out how to do this, by possibly doing something creative with the PT protocol

Child Tickets

Change History (6)

comment:1 Changed 7 months ago by teor

Owner: asn deleted
Status: newassigned

asn does not need to own any obfuscation tickets any more. Default owners are trouble.

comment:2 Changed 7 months ago by cohosh

Status: assignednew

tickets were assigned to asn, setting them as unassigned (new) again.

comment:3 Changed 7 months ago by kat5

Possibly related: #28849

comment:4 Changed 4 months ago by gaba

Keywords: network-team-roadmap-2019-Q1Q2 added

comment:5 Changed 3 months ago by phw

Sponsor: Sponsor19Sponsor28-must

Moving from Sponsor 19 to Sponsor 28.

comment:6 Changed 3 months ago by gaba

Resolution: duplicate
Status: newclosed

Closing this ticket as it is a duplicate of https://trac.torproject.org/projects/tor/ticket/28849

Note: See TracTickets for help on using tickets.