Opened 16 months ago

Closed 2 months ago

#29286 closed task (not a bug)

Maintain obfs4 proxy

Reported by: cohosh Owned by:
Priority: Medium Milestone:
Component: Circumvention/Obfs4 Version:
Severity: Normal Keywords: obfs4, maintainance, ex-sponsor-19
Cc: cohosh, yawning Actual Points:
Parent ID: Points:
Reviewer: Sponsor: Sponsor30-can

Description

This depends first on ticket #29279 and seeing what is possibly going wrong with obfs4 now.

Child Tickets

Change History (9)

comment:1 Changed 16 months ago by teor

Owner: asn deleted
Status: newassigned

asn does not need to own any obfuscation tickets any more. Default owners are trouble.

comment:2 Changed 16 months ago by yawning

Is this a out of season April fool's joke?

comment:3 Changed 16 months ago by yawning

Cc: yawning added

comment:4 Changed 16 months ago by ahf

While it may seem plausible that this is an off season April 1st joke since we are off exactly by two months from the 1st of April when this ticket was created, but no, that is not the case :-)

This ticket was created as part of a larger roadmap session we did in Brussels for Tor's new anti-censorship team that we have recently been hiring for. The ticket is by no means a "let's take over maintainership from Yawning" ticket or anything like that. It should be seen more as a tracker bug for us to remember to look into obfs4 and if there is anything we can help with around obfs4. For example: we have recently added the LOG and STATUS handlers in little-t-tor and adding support for that in obfs4 might be something we should do.

Our main focus is going to be on getting the Snowflake PT into a state where we can ship it with Tor browser, but we are also interested in helping out with anything around obfs4 wherever we can :-)

comment:5 Changed 16 months ago by cohosh

Status: assignednew

tickets are unassigned, reverting to 'new'

comment:6 Changed 13 months ago by phw

Component: Archived/ObfsproxyCircumvention/Obfs4

comment:7 Changed 12 months ago by gaba

Keywords: ex-sponsor-19 added

Adding the keyword to mark everything that didn't fit into the time for sponsor 19.

comment:8 Changed 12 months ago by phw

Sponsor: Sponsor19Sponsor30-can

Moving from Sponsor 19 to Sponsor 30.

comment:9 Changed 2 months ago by phw

Resolution: not a bug
Status: newclosed

I'm closing this ticket because it's not actionable.

The process for "maintaining" obfs4 is: write a patch and ask Yawning to merge.

Note: See TracTickets for help on using tickets.