Opened 7 months ago

Closed 7 months ago

#29341 closed defect (duplicate)

conn_proxy reported instead of conn_pt

Reported by: mcs Owned by:
Priority: Medium Milestone: Tor: 0.4.0.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tbb-needs
Cc: brade, catalyst Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am using Tor 0.4.0.1-alpha (git-81f1b89efc94723f) which ships as part of Tor Browser 8.5a7. When I use obfs4 as my PT, conn_proxy and the other _proxy tags are used within bootstrap status messages instead of conn_pt and friends. Unless I misunderstand something, this is wrong. Sample log output:

[notice] Bootstrapped 3% (conn_proxy): Connecting to proxy
[notice] Bootstrapped 4% (conn_done_proxy): Connected to proxy

The same tags are reported to the control port in the bootstrap status events and this same issue occurs with the meek PT and probably others.

Child Tickets

Change History (2)

comment:1 Changed 7 months ago by nickm

Cc: catalyst added
Milestone: Tor: 0.4.0.x-final

Could this be a duplicate of #28925?

comment:2 in reply to:  1 Changed 7 months ago by catalyst

Resolution: duplicate
Status: newclosed

Replying to nickm:

Could this be a duplicate of #28925?

Thanks, yes this looks like a duplicate of #28925.

Note: See TracTickets for help on using tickets.