Opened 9 months ago

Closed 9 months ago

#29441 closed defect (duplicate)

Certain websites detect OS as linux despite Windows NT UA

Reported by: HenkAnon Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In Tor Browser on Linux, some websites detect that I am on linux, even though the UA string claims that I am coming from Windows.

To replicate:

tor browser on linux
google.com/chrome
select download chrome
linux download is immediately selected

Child Tickets

Change History (2)

comment:1 Changed 9 months ago by Thorin

This is by design: see #26146 - the HTTP Header will return one of two OSes (Windows, Android), but the JS/navigator objects will report one of four OSes (Windows, Linux, MacOS, Android) due to breakage

Hopefully JS/navigator objects can be reduced to two OSes when https://bugzilla.mozilla.org/show_bug.cgi?id=1519122 lands as part of Tor Uplift

comment:2 Changed 9 months ago by boklm

Resolution: duplicate
Status: newclosed
Version: Tor: unspecified

Closing as duplicate of #28290.

Note: See TracTickets for help on using tickets.