Opened 8 years ago

Closed 8 years ago

#2945 closed defect (duplicate)

Vidalia stops Windows from shutting down

Reported by: chiiph Owned by: chiiph
Priority: Medium Milestone:
Component: Archived/Vidalia Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Migrated from old trac, ticket #501:

"First thought the problem I experience was related to something on my computer but after other users claimed to have the same problem, it could be a bug, so here is the (first&quick) bug report.

My system is a german Vista 64bit but it also occured on a XP Prof. 32bit and a Vista 32bit (language unknown)

Problem description: If you try to shut down your computer a error message appears which states something like: "Vidalia.exe is preventing Windows to shut down." If you click OK in the error box Windows continues to shut down.

In the Windows log there is an entry which states: "The following application tried to stop the shut down: vidalia.exe". Source of this message is "Winsrv" and ID is 10001. Unfortunately I did not copy the error message yet, but I will do that.

I use Vidalia 0.1.14 (german), Tor 0.2.1.16 and Qt 4.5.4, Tor acts as a middle node with a bandwithlimit around 60kb/s. No further configs where made.

If you have special requests for information, I'll try to help you as good as possible."

And a possible important comment:
"My gut feeling [it has to be that, 'cause I am no good with C/C++] tells me that Vidalia either has a bug in its event handler for WM_QUERYSHUTDOWN or it needs an event handler for WM_QUERYSHUTDOWN. "

Child Tickets

Change History (1)

comment:1 Changed 8 years ago by rransom

Resolution: duplicate
Status: newclosed

Duplicate of #2107.

Note: See TracTickets for help on using tickets.