Opened 5 months ago

Last modified 5 weeks ago

#29470 needs_information defect

error message torBrowser-8.0.5-osx6 No Mountable file systems

Reported by: arw54 Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: mcs, brade, arthuredelstein Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I keep receiving the above error message when install Tor Browser on iMac Pro using 10.14.3. Had no difficulty installing on other Macs with same software version. Repeatedly downloaded different versions of browser, restarted mac, etc. Thanks

Child Tickets

Change History (4)

comment:1 Changed 5 months ago by gk

Cc: mcs brade added
Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team

mcs/brade: Any ideas?

comment:2 Changed 5 months ago by mcs

Status: newneeds_information

When does this error message appear? As soon as you try to open the Tor Browser .dmg file?

I have a very fuzzy memory of a similar problem from several years ago. Usually this means that the downloaded DMG is corrupt. Please check the checksum. Also, the following articles might provide some useful ideas:
https://superuser.com/questions/19426/im-unable-to-mount-a-dmg-getting-a-no-mountable-filesystems-error
https://deciphertools.com/blog/2017-10-02-no-mountable-file-systems/

comment:3 Changed 5 weeks ago by gk

Alright we had a user on IRC today and we looked closer at it. The .dmgs were not corrupted during download and, yes, as far as I understand it the error happens as soon as Tor Browser gets opened.

Trying to figure something out on the commandline with hdiutil attach -verbose TorBrowser-8.5.1-osx64_nl.dmg gives:

Initialising… 
DIBackingStoreInstantiatorProbe: interface  0, score      100, 
CBSDBackingStore DIBackingStoreInstantiatorProbe: interface  1, 
score    -1000, CBundleBackingStore DIBackingStoreInstantiatorProbe: 
interface  2, score    -1000, CRAMBackingStore 
DIBackingStoreInstantiatorProbe: interface  3, score      100, 
CCarbonBackingStore DIBackingStoreInst
Mounting… 2019-06-14 07:58:37.407 diskimages-helper[12882:447676] 
-remountReturningDictionary: detaching because no mountable 
filesystems. 2019-06-14 07:58:37.408 diskimages-helper[12882:447673] 
_postflightMountPointsAfterDAMount: disk6 aborting because disk 
image has no band size specified. Attaching… Error 112 (no mountable 
file systems). Finishing… DIHLDiskImageAttach() returned 112 
hdiutil: attach failed - no mountable file systems

Then we tried to get things running on an USB stick with minimum security but still no dice.

Use right click "Open With" - "DiskImageMounter (default) to start mounting dmg files. Same issue again via usb Did this action via Finder and PathFinder

Then I pointed to https://superuser.com/questions/19426/im-unable-to-mount-a-dmg-getting-a-no-mountable-filesystems-error
here is what happened:

I first followed the lines in Terminal as follows
`hdiutil attach -noverify -nomount TorBrowser-8.5.1-osx64_en-US.dmg`
 feedback Terminal in my case /dev/disk7
Then I entered in Terminal diskutil list
That shows me indeed all the drives as well as disk7
Then Terminal command diskutil mountDisk /dev/disk7
Feedback Terminal -> Volume(s) mounted successfully
So it all seems OK, but it wasn't yet sine there was nothing mounted. Then I went to Disk Utility and follow the article to the moment ..... to this paragraph -> 
I ran into a similar situation. I did what simonair suggested and I received a message in Terminal that Volume mounted successfully. However It did not help me access the mounted Volume neither was I                 able to confirm the mounted Volume. Nor was I able to mount the image using Disk Drill or even scan through. Nothing succeeded.
Then there's a long paragraph telling to make a new image of the Tor Browser which seems not to be active thus Disk Utility - File - New Image - Image from tor browser. I kept all default values and it was made. Only thing I don't understand it what the file size is now 154MB, but besides that ....
I clicked the newly created tor browser and now it opened without a fault message
Copied the Tor to Applications, started Tor and it works flawless

So, recreating the image locally seems to solve this. This is a bit inconvenient but looking at the StackExchange article it seems this is not a Tor Browser (only) issue as a bunch of different .dmg images are affected.

Should we declare victory here and just add an item to our browser FAQs/support pages? I am not too famiilar with macOS but this seems more like an macOS issue to me than something to fix on our turf.

comment:4 Changed 5 weeks ago by gk

Cc: arthuredelstein added
Note: See TracTickets for help on using tickets.