Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#2948 closed defect (fixed)

rend_parse_v2_service_descriptor checks wrong length

Reported by: rransom Owned by: rransom
Priority: Medium Milestone: Tor: 0.2.2.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

2011-03-13 23:45 <hsdir> last one. rend_parse_v2_service_descriptor() by design allows several descs in the string. REND_DESC_MAX_SIZE limiting all of them not one.
2011-03-13 23:47 <hsdir> what for parser wait for "\nrendezvous-service-descriptor " if 20kb is limit for string.

(split from #2750)

Child Tickets

Change History (4)

comment:1 Changed 9 years ago by rransom

Status: newneeds_review

See bug2948 ( ssh://mob@repo.or.cz/srv/git/tor/rransom.git bug2948 ) for nickm's fix.

comment:2 Changed 9 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

looks fine, merging.

comment:3 Changed 7 years ago by nickm

Keywords: tor-relay added

comment:4 Changed 7 years ago by nickm

Component: Tor RelayTor
Note: See TracTickets for help on using tickets.