Opened 6 months ago

Closed 6 months ago

#29514 closed defect (duplicate)

Alt+Ctrl+R and Polish and Czech programist keyboard

Reported by: Crissy Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords:
Cc: tbb-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The Tor Browser restart and crashes after typing AltGR+R This sequence is reserved in Poland and Czech for diacritic letters. Please differentiate Alt+Ctrl+R and AltGR+R. It is very embarrassing!

I do not need shortcut for Restart Browser. I can reach it by tor button!

Additionally in part of languages AltGR+E is used for national characters. A typo AltGR+R anistead AltGR+E restart my browser!!! I do not know how to blacklist the Alt+Ctrl+R to stop restart my browser

:angry:

Is there any workaround for it?

Version 8.0.5. Win32.

Child Tickets

Change History (4)

comment:1 Changed 6 months ago by mcs

Status: assignedneeds_information

I think this problem is caused by a difference in how we build Tor Browser for Windows (compared to how Firefox release builds are created). The fix for #28618 should make this problem disappear. For now it is only available in our alpha series, but please try it and let us know if it resolves this issue. You can find our latest alpha builds here:
https://dist.torproject.org/torbrowser/8.5a8/

comment:2 Changed 6 months ago by Crissy

Is there no option to disable (for example in about:config) the Alt+Ctrl+R shortcut in stable version of TB?

Last edited 6 months ago by Crissy (previous) (diff)

comment:3 in reply to:  2 Changed 6 months ago by mcs

Replying to Crissy:

Is there no option to disable (for example in about:config) the Alt+Ctrl+R shortcut in stable version of TB?

No, I do not think there is a way to disable it without the fix for #28618 or another change to the browser code. The code that adds the shortcut is here in case someone else wants to look:
https://gitweb.torproject.org/tor-browser.git/tree/browser/base/content/browser-development-helpers.js?h=tor-browser-60.5.1esr-8.0-1#n26

Did you get a chance to try Tor Browser 8.5a8 to confirm that it does not have this issue?

comment:4 Changed 6 months ago by gk

Resolution: duplicate
Status: needs_informationclosed

Smells like #28618. Duping this over. Please reopen if that's not the case.

Note: See TracTickets for help on using tickets.