Opened 8 months ago

Closed 8 months ago

#29534 closed defect (fixed)

Regression: map_anon_nofork test is breaking jenkins on some platforms

Reported by: nickm Owned by: nickm
Priority: Very High Milestone: Tor: 0.4.0.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: regression
Cc: Actual Points:
Parent ID: Points:
Reviewer: dgoulet Sponsor:

Description (last modified by nickm)

This test from the fast_rng branch is breaking jenkins CI in some cases:

17:39:20 util/map_anon_nofork: 
17:39:20   FAIL ../tor/src/test/test_util.c:6206: assert((int)r OP_EQ 1): 0 vs 1
17:39:20   [map_anon_nofork FAILED]

I suspect this is about kernel/header mismatch, but I need to check more closely.

I think we should disable this test in 0.4.0 (since the code is unused) and look for better solutions in 0.4.1.

Child Tickets

Change History (4)

comment:1 Changed 8 months ago by nickm

Component: - Select a componentCore Tor/Tor
Description: modified (diff)
Milestone: Tor: 0.4.0.x-final
Summary: Regression:Regression: map_anon_nofork test is breaking jenkins on some platforms

comment:2 Changed 8 months ago by nickm

Keywords: regression added
Priority: MediumVery High
Status: assignedneeds_review

See my branch ticket29534_040 for the 0.4.0 fix (disabling the test). PR at https://github.com/torproject/tor/pull/712.

I would like to take this ASAP, so CI can pass again.

comment:3 Changed 8 months ago by dgoulet

Reviewer: dgoulet
Status: needs_reviewmerge_ready

ack

comment:4 Changed 8 months ago by arma

Resolution: fixed
Status: merge_readyclosed

It is merged!

Note: See TracTickets for help on using tickets.