Opened 4 weeks ago

Closed 4 weeks ago

#29538 closed task (not a bug)

Coverage fails on master

Reported by: teor Owned by:
Priority: Very High Milestone: Tor: 0.4.0.x-final
Component: Core Tor/Tor Version:
Severity: Major Keywords: tor-ci, tor-test, external-failure, 040-must
Cc: Actual Points: 0.3
Parent ID: Points: 1
Reviewer: Sponsor:

Description

Since about 24 hours ago, coveralls is failing.
The bot isn't posting GitHub comments, and coveralls.io has some builds, with no coverage data.

The last pull request with a bot comment was at 14:39 UTC on 17 Feb:
https://github.com/torproject/tor/pull/708

Sometimes, the repository isn't found:

{u'message': u"Couldn't find a repository matching this job.", u'error': True}

https://travis-ci.org/torproject/tor/jobs/495420447#L7333

Sometimes, the coverage is uploaded, but the analysis has no data:

{u'url': u'https://coveralls.io/jobs/45356536', u'message': u'Job #3861.6'}

https://travis-ci.org/torproject/tor/jobs/495759411#L7330
https://coveralls.io/jobs/45356536

I don't know if this is a coveralls failure, a Travis failure, a GitHub failure, or a change in our code.

Child Tickets

Change History (7)

comment:1 Changed 4 weeks ago by teor

I opened two pull requests with dummy commits:

If both fail to get coverage, it's an external issue.
If the latest fails, it's our code, likely merged 24-48 hours ago.

comment:2 Changed 4 weeks ago by nickm

Keywords: 040-must added

Marking tickets as 040-must based on triage with dgoulet.

comment:3 in reply to:  1 Changed 4 weeks ago by teor

Replying to teor:

I opened two pull requests with dummy commits:

If both fail to get coverage, it's an external issue.

Both tests did not have coverage comments from the coveralls bot on GitHub.

Both tests ended successfully, with a message like this:

{u'url': u'https://coveralls.io/jobs/45358787', u'message': u'Job #3862.6'}
Done. Your build exited with 0.

https://travis-ci.org/torproject/tor/jobs/495786483#L7333
https://travis-ci.org/torproject/tor/jobs/495787030#L7333

Both tests have coverage reports with data on coveralls.io :
https://coveralls.io/jobs/45358787
https://coveralls.io/jobs/45359147
(Yesterday's jobs had empty coverage reports.)

It looks like the "job not found" errors were a coveralls.io issue:
http://status.coveralls.io/incidents/wzpyvx3lrpzt

coveralls.io currently has a job processing backlog:
http://status.coveralls.io/incidents/g5h0ffcdrpn7

Next steps:

Monitor pull requests over the next few days, and make sure they get coveralls bot comments.

comment:4 Changed 4 weeks ago by teor

Actual Points: 0.2
Keywords: external-failure added; regression? external-failure? removed
Type: defecttask

comment:5 Changed 4 weeks ago by teor

Some older pull requests were missing coveralls bot comments yesterday and the day before.
Now they have comments:
https://github.com/torproject/tor/pull/709#issuecomment-465408842

comment:6 Changed 4 weeks ago by teor

#29435 might also be related - we were looking for coverage files in the wrong locations.

comment:7 in reply to:  6 Changed 4 weeks ago by teor

Actual Points: 0.20.3
Resolution: not a bug
Status: newclosed
Version: Tor: unspecified

Replying to teor:

#29435 might also be related - we were looking for coverage files in the wrong locations.

Actually, I think that's a different script.

coveralls seems to have recovered and processed their backlog.
If any pull requests are missing a coverage report, please re-run the coverage build.

If you don't have the permissions to launch builds on Travis:

  • login to Travis with your GitHub account,
  • close and re-open the pull request,
  • push another commit, or
  • open a trac ticket and someone will do it for you
Note: See TracTickets for help on using tickets.