Opened 5 months ago

Last modified 5 months ago

#29547 new enhancement

Disable merging to unsupported branches on origin

Reported by: teor Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: git-scripts
Cc: rl1987 Actual Points:
Parent ID: Points: 1
Reviewer: Sponsor:

Description

In our release meeting in Brussels, we talked about disabling merges to unsupported branches:
https://trac.torproject.org/projects/tor/wiki/org/meetings/2019BrusselsNetworkTeam/Notes/StableMaintainer#ActionItems

In particular, we should only allow merges to current release and maint branches, and master.

Here is a list of current releases (prefixed with release- and maint-):

  • 0.2.9 (LTS)
  • 0.3.3 (expires 28 February 2019)
  • 0.3.4
  • 0.3.5 (LTS)
  • 0.4.0
  • 0.4.1 (in git, 0.4.1 is the master branch at the moment)

We should also allow:

  • master

https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam/CoreTorReleases#Current

Child Tickets

Change History (2)

comment:1 Changed 5 months ago by nickm

See also #29532

comment:2 Changed 5 months ago by rl1987

Cc: rl1987 added
Note: See TracTickets for help on using tickets.