#29550 closed defect (fixed)

Tor nightly fails to build for Windows

Reported by: boklm Owned by:
Priority: High Milestone: Tor: 0.4.0.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tbb-needs, 040-must
Cc: tbb-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Since 2019-02-15, tor fails to build for Windows inside the Tor Browser nightly builds.

It fails with this error:

  CCLD     src/tools/tor-gencert.exe
  CCLD     src/test/test-switch-id.exe
  CCLD     src/test/test-timers.exe
  CCLD     src/test/test-bt-cl.exe
  CCLD     src/test/test-rng.exe
  CCLD     src/test/fuzz/fuzz-consensus.exe
  CCLD     src/test/fuzz/fuzz-descriptor.exe
  CCLD     src/test/fuzz/fuzz-diff.exe
  CCLD     src/test/fuzz/fuzz-diff-apply.exe
  CCLD     src/test/fuzz/fuzz-extrainfo.exe
  CCLD     src/test/fuzz/fuzz-hsdescv2.exe
  CCLD     src/test/fuzz/fuzz-hsdescv3.exe
  CCLD     src/test/fuzz/fuzz-http.exe
  CCLD     src/test/fuzz/fuzz-http-connect.exe
  CCLD     src/test/fuzz/fuzz-iptsv2.exe
  CCLD     src/test/fuzz/fuzz-microdesc.exe
  CCLD     src/test/fuzz/fuzz-socks.exe
  CCLD     src/test/fuzz/fuzz-strops.exe
  CCLD     src/test/fuzz/fuzz-vrs.exe
  CCLD     src/app/tor.exe
  CCLD     src/tools/tor-resolve.exe
  CCLD     src/tools/tor-print-ed-signing-cert.exe
  CCLD     src/test/bench.exe
  CCLD     src/test/test.exe
  CCLD     src/test/test-slow.exe
/var/tmp/dist/mingw-w64/lib/gcc/i686-w64-mingw32/6.4.0/../../../../i686-w64-mingw32/bin/ld: cannot find -lz
collect2: error: ld returned 1 exit status
make[1]: *** [src/test/test-slow.exe] Error 1
Makefile:8673: recipe for target 'src/test/test-slow.exe' failed
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory '/var/tmp/build/tor-59c3910becd9'
Makefile:5290: recipe for target 'all' failed
make: *** [all] Error 2

Child Tickets

Attachments (1)

0001-Make-test-slow-compile-with-zlib.patch (905 bytes) - added by boklm 10 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 months ago by boklm

Status: newneeds_review

The attached patch 0001-Make-test-slow-compile-with-zlib.patch is fixing the build for me.

comment:2 Changed 10 months ago by boklm

Keywords: tbb-needs added

comment:3 Changed 10 months ago by boklm

Keywords: 040-must added
Priority: MediumHigh

comment:4 Changed 10 months ago by nickm

Milestone: Tor: 0.4.0.x-final

comment:5 Changed 10 months ago by boklm

I think the issue might be caused by this change from commit acbde10fce5d688d70b5a4bfb3a736da838bb4cc:

-src_test_test_slow_LDFLAGS = $(src_test_test_LDFLAGS)
+src_test_test_slow_LDFLAGS =@TOR_LDFLAGS_openssl@

comment:6 Changed 10 months ago by nickm

In that case, it's probably better to revert that LDFLAGS change; it looks like a mistake.

comment:7 Changed 10 months ago by nickm

Resolution: fixed
Status: needs_reviewclosed

34183f0d71c2e2d10e3d64291e3bb83a27c2416a is a fix here; I've applied it to 0.4.0 and forward.

Note: See TracTickets for help on using tickets.