Opened 5 months ago

Closed 5 months ago

#29586 closed defect (not a bug)

Intermittent test failures in relay/close_circ_rephist

Reported by: teor Owned by:
Priority: High Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.3.5.2-alpha
Severity: Normal Keywords: tor-ci, tor-test
Cc: mikeperry Actual Points:
Parent ID: Points: 1
Reviewer: Sponsor:

Description (last modified by teor)

I observed this failure once out of about 10 tests when testing #29541 on commit:

commit 5614960e94 (HEAD, tor-github/pr/723/merge)
Merge: 69238ca2da 065e7da8e6

Here is the test error:

relay/close_circ_rephist: [forking] 
  FAIL ../src/test/test_relay.c:127: assert(find_largest_max(write_array) OP_EQ 2*(get_cell_network_size(nchan->wide_circ_ids) +TLS_PER_CELL_OVERHEAD)): 0 vs 1082
  [close_circ_rephist FAILED]

It looks like this test was introduced in #23512 for Sponsor Q.
Is Sponsor Q still open?

Is it an obvious fix?
If not, let's see if it happens again.

Child Tickets

Change History (3)

comment:1 Changed 5 months ago by teor

#29585 and #29586 occurred in the same test run: what do they both do that might have failed?

comment:2 Changed 5 months ago by teor

Description: modified (diff)

Be more precise: it only failed once

comment:3 Changed 5 months ago by teor

Resolution: not a bug
Status: newclosed

We think this issue happened due to a clock change during the test run. If it happens again, we can reopen this ticket.

Note: See TracTickets for help on using tickets.