Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#29593 closed defect (worksforme)

channelpadding_timers test failed on tor-0.3.5.8

Reported by: asn Owned by: nickm
Priority: High Milestone: Tor: 0.4.0.x-final
Component: Core Tor/Tor Version:
Severity: Normal Keywords: channel-padding padding unit-test 040-unreached-must 035-unreached-backport
Cc: mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

weasel reported the following test failure today:

channelpadding/channelpadding_timers: [forking] Feb 22 09:58:55.345 [err] tor_assertion_failed_(): Bug: ../src/test/testing_rsakeys.c:540: 
init_pregenerated_keys: Assertion r == 0 failed; aborting. (on Tor 0.3.5.8 )
Feb 22 09:58:55.347 [err] Bug: Assertion r == 0 failed in init_pregenerated_keys at ../src/test/testing_rsakeys.c:540. Stack trace: (on Tor 0.3.5.8 )
Feb 22 09:58:55.348 [err] Bug:     ./src/test/test(log_backtrace_impl+0x84) [0x569abc28] (on Tor 0.3.5.8 )
Feb 22 09:58:55.348 [err] Bug:     ./src/test/test(tor_assertion_failed_+0xc4) [0x569a67b8] (on Tor 0.3.5.8 )
Feb 22 09:58:55.348 [err] Bug:     ./src/test/test(init_pregenerated_keys+0x198) [0x5678f770] (on Tor 0.3.5.8 )
Feb 22 09:58:55.349 [err] Bug:     ./src/test/test(testcase_run_one+0x284) [0x5678fb14] (on Tor 0.3.5.8 )
Feb 22 09:58:55.349 [err] Bug:     ./src/test/test(tinytest_main+0x188) [0x56790490] (on Tor 0.3.5.8 )
Feb 22 09:58:55.349 [err] Bug:     ./src/test/test(main+0x43c) [0x563dca5c] (on Tor 0.3.5.8 )
Feb 22 09:58:55.349 [err] Bug:     /lib/mips-linux-gnu/libc.so.6(__libc_start_main+0x108) [0x76d422b8] (on Tor 0.3.5.8 )
Feb 22 09:58:55.350 [err] Bug:     ./src/test/test(+0x5fbd4) [0x563dcbd4] (on Tor 0.3.5.8 )
[Lost connection!] 
  [channelpadding_timers FAILED]
channeltls/create: [forking] OK

from https://buildd.debian.org/status/fetch.php?pkg=tor&arch=mips&ver=0.3.5.8-1&stamp=1550830462&raw=0

Apparently, if this is not dealt with, it'll mean 0.3.5.8 will not ship with the next Debian

Child Tickets

Change History (7)

comment:1 Changed 6 months ago by asn

Keywords: 040-must 035-backport added

comment:2 Changed 6 months ago by mikeperry

This failure has nothing to do with channelpadding. It's an assert due to crypto_pk_read_private_key_from_string() returning an error code while parsing one of PREGEN_KEYS_2048[] from ./src/test/testing_rsakeys.c

Possibly a MIPS-specific openssl-related issue? Should not be intermittent unless our key parsing is non-deterministic...

If we ran the tests with log level info, then crypto_pk_read_from_string_generic() will output a logline telling us if the error is in PEM decoding or ASN.1 parsing. Not sure if that will be any more helpful, though.

comment:3 Changed 6 months ago by weasel

Tor built and passed its test suite on a retry --

https://buildd.debian.org/status/logs.php?pkg=tor&ver=0.3.5.8-1&arch=mips

Not sure what to take from this.

comment:4 Changed 5 months ago by teor

Owner: set to nickm
Status: newassigned

I think nickm is the best person to work out what information we need (or if we can just close this ticket as a once-off failure.)

comment:5 Changed 5 months ago by teor

Milestone: Tor: 0.3.5.x-finalTor: 0.4.0.x-final

We want to fix this issue in 0.4.0. (Or triage it out.)

comment:6 Changed 5 months ago by nickm

Resolution: worksforme
Status: assignedclosed

Given what we have, I'm also not sure what to make of this. Given that it only appears to have happened once, and only on MIPS, I don't know how to reproduce it, and I'm not really sure what could have caused it. I'm going to close this as worksforme, but let's reopen if it happens again, especially if it happens reproducibly.

comment:7 Changed 5 months ago by teor

Keywords: 040-unreached-must 035-unreached-backport added; 040-must 035-backport removed

Marking tags as unreached.

Note: See TracTickets for help on using tickets.