Opened 10 months ago

Closed 9 months ago

#29643 closed defect (fixed)

Fix an incorrect comment about calling FreeLibrary()

Reported by: teor Owned by: teor
Priority: Medium Milestone: Tor: 0.4.0.x-final
Component: Core Tor/Tor Version: Tor: 0.2.9.1-alpha
Severity: Normal Keywords: 040-backport, fast-fix, tor-windows, memory-management, technical-debt
Cc: Actual Points: 0.1
Parent ID: #29642 Points: 0.1
Reviewer: cohosh Sponsor:

Description

There's an incorrect comment in compat_time.c about calling FreeLibrary().

See #29642 for background.

Child Tickets

Change History (8)

comment:1 Changed 10 months ago by teor

Actual Points: 0.1
Keywords: 040-backport added
Status: assignedneeds_review
Summary: Fix an incorrect comment about calling FreeLinrary()Fix an incorrect comment about calling FreeLibrary()

See my pull request on 0.4.0:
https://github.com/torproject/tor/pull/756

Since 0.4.0 is in alpha, we might want to backport documentation fixes.

comment:2 Changed 10 months ago by teor

Hmm, there are two pull requests open for this ticket. I can't close either of them, because it will break the CI.

I started using Firefox to open pull requests last week, and it's happened twice since then. Maybe GitHub hasn't tested high-latency connections with Firefox?

comment:3 Changed 10 months ago by teor

The master pull request failed due to #29644. It's intermittent and unrelated to this change.

comment:4 Changed 10 months ago by teor

The maint-0.4.0 pull request failed due to #29645. It is not reproducible, and it is unrelated to this change.

comment:5 Changed 10 months ago by dgoulet

Reviewer: ahf

comment:6 Changed 10 months ago by asn

Reviewer: ahfcohosh

comment:7 Changed 9 months ago by cohosh

Status: needs_reviewmerge_ready

Looks good!

comment:8 Changed 9 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

Merged to 0.4.0 and forward!

Note: See TracTickets for help on using tickets.