Opened 11 months ago

Closed 9 days ago

#29655 closed defect (fixed)

Tor Metrics / Users / Bridge users by country and transport / Source: China, fails to render graph lines clearly

Reported by: monmire Owned by: metrics-team
Priority: Medium Milestone:
Component: Metrics Version:
Severity: Normal Keywords: Tor-Metrics-graph issue
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

— After selecting Source: China, Germany, and some other country names, the <OR>, meek, and obfs4 graph lines appear washed out, faint, and indistinct. This defect has persisted for approximately the past 2 weeks or longer.

https://metrics.torproject.org/userstats-bridge-combined.html?start=2018-12-04&end=2019-03-04&country=cn

Child Tickets

Change History (4)

comment:1 Changed 11 months ago by monmire

Summary: Tor Metrics / Users / Bridge users by country and transport / Source: China fails to render graph lines clearlyTor Metrics / Users / Bridge users by country and transport / Source: China, fails to render graph lines clearly

comment:2 Changed 11 months ago by karsten

Resolution: fixed
Status: newclosed

True, this doesn't look good. The issue is that upper and lower bound of our estimate were so close together that the ribbon between the two was almost invisible. I changed the graph to also display upper and lower bounds using a solid line. It should look better now. Closing. Thanks for the report!

comment:3 Changed 4 months ago by monmire

Resolution: fixed
Status: closedreopened

Graphs of Bridge users by country and transport Source do not show solid lines for the average number of connections.

For example, the graph of Bridge users by country and transport Source: Venezuela https://metrics.torproject.org/userstats-bridge-combined.html?start=2019-09-10&end=2019-09-16&country=ve shows ribbons and solid lines for the low and high bounds of <OR>, meek, and obfs4 connections, but it does not show solid lines for the average number of <OR>, meek, and obfs4 connections.

Would not solid lines showing the average number of <OR>, meek, and obfs4 connections allow users to gauge visually, more quickly and more accurately, the average number of connections during a defined date interval or on certain dates?

For each Source, can we have solid lines showing the average number of connections for <OR>, meek, and obfs4?

comment:4 Changed 9 days ago by karsten

Resolution: fixed
Status: reopenedclosed

I understand how an average number in the graph, probably computed as (high+low)/2, would feel like a usability improvement. However, we don't have a model telling us that that's the most likely number of users. We only know that the number cannot be higher than high nor lower than low, but it could be anything between the two. If we had a better model for computing an average value, we should plot that. But we cannot plot something we don't have. Sorry! Re-closing.

Note: See TracTickets for help on using tickets.