Opened 9 months ago

Closed 9 months ago

#29763 closed defect (fixed)

Fix 0.2.9 failures in chutney CI

Reported by: teor Owned by: teor
Priority: Medium Milestone:
Component: Core Tor/Chutney Version:
Severity: Normal Keywords: chutney-ci, network-team-roadmap-2019-Q1Q2
Cc: teor Actual Points:
Parent ID: #29729 Points:
Reviewer: Sponsor:

Description

In #29761, we discovered that 0.2.9 often fails, and when one allow failures run fails, the next fails too.

I want to add a sleep between allow failures rounds to hopefully allow 0.2.9 to recover.

Should we only add the sleep for 0.2.9?
Probably, otherwise we won't notice regressions.

We might also need to:

  • adjust the 0.2.9 bootstrap timings
  • remove 0.2.9 from CI

Child Tickets

Change History (5)

comment:1 Changed 9 months ago by teor

Keywords: network-team-roadmap-2019-Q1Q2 added

These chutney tickets are on the network team roadmap, or they are required for tickets that are on the network team roadmap.

comment:2 Changed 9 months ago by teor

I think the 0.2.9 issue might be caused by timing differences between 0.2.9 and 0.3.4 and later. (In 0.3.3, we changed many events in the event loop from "once per second" to "as often as possible".)

Here's what I'd like to try to fix this issue:

  1. Fix #22132 and #28203, so that we start testing once 0.2.9 has bootstrapped
  2. Disable (parts of) the change in b0e98fcc for 0.2.9
    • "Fix a common Travis failure mode by allowing tor more time to bootstrap. And double the consensus interval."
  3. Implement #29729, #28204, and #28220 to find out how bad the problem is, and where it's happening
  4. Work out how to get a copy of the whole chutney directory so we can check the logs

comment:3 Changed 9 months ago by teor

I haven't seen any of these failures since we implemented #22132. Let's continue to monitor and close this bug if we don't see any in the next week?

comment:4 Changed 9 months ago by teor

Parent ID: #29761#29729

Flatten tree: we might need this for #29729.

comment:5 Changed 9 months ago by teor

Resolution: fixed
Status: assignedclosed

This issue seems to be fixed by the bootstrap changes, let's open specific bugs for failures.

Note: See TracTickets for help on using tickets.