Opened 9 months ago

Closed 9 months ago

#29767 closed defect (duplicate)

Prob distr stochastic tests fail CI (innocuous?)

Reported by: asn Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-test prob-distr math tor-ci
Cc: Actual Points:
Parent ID: #29693 Points:
Reviewer: Sponsor:

Description

The stochastic tests are failing the CI as we expected. This is a ticket to collect such failures, to eventually see if they are really innocuous or there is some underlying bug. At this point I have two such failures collected both for the same stochastic test (log-logistic):

slow/prob_distr/stochastic_log_logistic: [forking] fail log logistic sampler
another stochastic test fail 
Seed: D3CF5E3899188E3357D47061E936FF96
slow/prob_distr/stochastic_log_logistic: [forking] fail log logistic sampler

  FAIL ../src/test/test_prob_distr.c:1390: assert(ok)
NOTE: This is a stochastic test, and we expect it to fail from
time to time, with some low probability. If you see it fail more
than one trial in 100, though, please tell us.

Seed: 883CEA3493C96F8D59EE7A6554EB594E

Child Tickets

Change History (1)

comment:1 Changed 9 months ago by teor

Parent ID: #29693
Resolution: duplicate
Status: newclosed

Duplicate of #29693

Note: See TracTickets for help on using tickets.