Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#29812 closed defect (fixed)

.mar files for 32-bit Linux are missing for 8.5a9

Reported by: gk Owned by: tbb-team
Priority: Immediate Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201903R, tbb-rbm, tbb-8.5
Cc: boklm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Probably due to our switch to cross-compile our Linux bundles (#26323) we don't have any .mar files for 32-bit Linux anymore.

Child Tickets

Change History (11)

comment:1 Changed 4 months ago by gk

So, the problem is we are using the 32bit mar-tools .zip file on a 64bit machine. Which does not work very well.

Last edited 4 months ago by gk (previous) (diff)

comment:2 Changed 4 months ago by gk

I think one quick workaround could be to include the 64-bit built Firefox part, too, in the bundling step and making sure we take the mar-tools from that one for generating the mar files. It's clumsy and I hope we can make the workaround even less so, but that's the best idea I can currently come up with.

However, what we actually want is to have both 32-bit and 64-bit mar-tools built when building the 32-bit Firefox code. That way we'd skip the inclusion and build of an additional 64-bit version of the firefox project if one just wants to build the 32-bit version and nothing else. We'd then extract the 64-bit mar-tools for update file generation in the 32-bit tor-browser build script while bundling the 32-bit mar-tools as usual.

Last edited 4 months ago by gk (previous) (diff)

comment:3 Changed 4 months ago by gk

Oh, and what we additionally want is to find this issue earlier (even though it should not happen that often). So, some check that .mar files actually got built when they are supposed to get built would be smart (I'll leave that here even though it's probably worth a new ticket).

comment:4 Changed 4 months ago by gk

Keywords: tbb-rbm tbb-8.5 added

comment:5 in reply to:  1 Changed 4 months ago by boklm

Replying to gk:

So, the problem is we are using the 32bit mar-tools .zip file on a 64bit machine. Which does not work very well.

Hmm, I am not sure exactly why exactly it does not work, as in theory we should be able to run 32bit binaries in our 64bit container. So maybe this is something we can fix, after finding what is causing the issue.

comment:6 Changed 4 months ago by boklm

In logs/tor-browser-linux-i686.log I can see some errors like:

Adding symlink add instructions to update manifests

Adding file and directory remove instructions from file 'removed-files'
/var/tmp/tmp.on3obHmYW7/mar-tools/make_full_update.sh: line 170: /var/tmp/tmp.on3obHmYW7/mar-tools/mar: No such file or directory
mv: cannot stat `/var/tmp/dist/tor-browser/tor-browser_zh-TW/Browser.work/output.mar': No such file or directory

Finished

comment:7 Changed 4 months ago by boklm

I think installing the libc6-i386 package in the projects/tor-browser step should fix the issue.

comment:8 Changed 4 months ago by boklm

Keywords: TorBrowserTeam201903R added; TorBrowserTeam201903 removed
Status: newneeds_review

There is a patch for review in branch bug_29812:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_29812&id=8c24ddebf61181511938408565a50eda4d083fee

I started a build with this patch and can see that mar files are now getting generated.

comment:9 in reply to:  3 ; Changed 4 months ago by boklm

Replying to gk:

Oh, and what we additionally want is to find this issue earlier (even though it should not happen that often). So, some check that .mar files actually got built when they are supposed to get built would be smart (I'll leave that here even though it's probably worth a new ticket).

I think this is #26907.

comment:10 in reply to:  8 Changed 4 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Replying to boklm:

There is a patch for review in branch bug_29812:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_29812&id=8c24ddebf61181511938408565a50eda4d083fee

I started a build with this patch and can see that mar files are now getting generated.

Thanks, that's much easier than what I came up with. Merged to master 8c24ddebf61181511938408565a50eda4d083fee.

comment:11 in reply to:  9 Changed 4 months ago by gk

Replying to boklm:

Replying to gk:

Oh, and what we additionally want is to find this issue earlier (even though it should not happen that often). So, some check that .mar files actually got built when they are supposed to get built would be smart (I'll leave that here even though it's probably worth a new ticket).

I think this is #26907.

Yeah, with the error that's true. I was just wondering whether we should safeguard against .mar files not being created even if no errors during the creation steps themselves are thrown (because maybe they are not even triggered or whatever). However, I am fine starting with #26907 first and then think more about it.

Note: See TracTickets for help on using tickets.