Opened 5 weeks ago

Last modified 3 weeks ago

#29826 assigned defect

Rename router_status_t to avoid confusion with routerstatus_t

Reported by: teor Owned by: neel
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: technical-debt, fast-fix, easy, intro
Cc: Actual Points:
Parent ID: Points: 0.2
Reviewer: Sponsor:

Description (last modified by teor)

Tor has routerstatus_t in many files, and a router_status_t in process_descs.c.

That's terribly confusing, we should rename router_status_t.

Child Tickets

Change History (4)

comment:1 Changed 5 weeks ago by teor

This change would conflict with #22029, so we should do it after #22029 merges.

comment:2 Changed 5 weeks ago by teor

Summary: Rename router_status_t, to avoid confusion with routerstatus_tRename router_status_t to avoid confusion with routerstatus_t

comment:3 Changed 5 weeks ago by teor

Description: modified (diff)

More typos

comment:4 Changed 3 weeks ago by neel

Owner: set to neel
Status: newassigned
Note: See TracTickets for help on using tickets.