Opened 4 months ago

Closed 3 months ago

#29843 closed task (fixed)

Backport fix for bug 1527534 for Tor Browser for Android

Reported by: gk Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-8.5-must, TorBrowserTeam201904R, GeorgKoppen201904
Cc: sysrqb Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Bug 1527534 got fixed in Firefox 66 but not backported to ESR 60 because Mozilla is not shipping any mobile browser based on ESR. But we do and should backport the patch.

Child Tickets

Change History (8)

comment:1 Changed 4 months ago by gk

Keywords: GeorgKoppen201903 added

comment:2 Changed 4 months ago by gk

Keywords: TorBrowserTeam201903R added; TorBrowserTeam201903 removed
Status: newneeds_review

bug_29843 (https://gitweb.torproject.org/user/gk/tor-browser-build.git/commit/?h=bug_29843&id=b619af79d04bde9313d8a4a2696c4a5a06c60175) in my tor-browser-build repo has the backport. I went that route because I don't want to have the desktop platforms exposed to the backport as it did not get any ESR testing on Mozilla's infra (Mozilla did not backport the patch themselves as they are not shipping mobile based on ESR).

It is compiling and the build is running on my phone. However, I did not get WebGL to run to further test the patch. Not sure what the problem is...

comment:3 Changed 4 months ago by sysrqb

Seems reasonable. It's a little ugly, but I agree this is a safer method of applying the patch than applying it on all platforms. I haven't tested the patch yet, but it looks good. I'll confirm tomorrow.

comment:4 Changed 4 months ago by gk

Keywords: tbb-8.5-must added; tbb-8.5 removed

Marking blockers for Tor Browser 8.5.

comment:5 Changed 4 months ago by gk

Keywords: TorBrowserTeam201904R added; TorBrowserTeam201903R removed

Moving review tickets to April.

comment:6 Changed 3 months ago by gk

Keywords: GeorgKoppen201904 added; GeorgKoppen201903 removed

Moving my tickets for April

comment:7 Changed 3 months ago by sysrqb

Status: needs_reviewmerge_ready

I can't easily test this on an older Android version due to #29906, but it works without any apparent issues on newer versions - therefore lgtm.

comment:8 Changed 3 months ago by gk

Resolution: fixed
Status: merge_readyclosed

Thanks, it should be in the next nightly so you could easily double-check that way :) Anyway, merged to tor-browser-build's master (commit 3ba210064197298ad1c54ca74f086a67653109a2).

Note: See TracTickets for help on using tickets.