Opened 4 months ago

Closed 4 months ago

#29869 closed defect (fixed)

FallbackDir flag incorrect in Relay Search

Reported by: starlight Owned by: irl
Priority: Immediate Milestone:
Component: Metrics/Relay Search Version:
Severity: Normal Keywords:
Cc: metrics-team Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

per summary

Child Tickets

Change History (6)

comment:1 Changed 4 months ago by teor

What are you seeing?

What do you expect to see?

Why do you expect to see something different?

comment:2 Changed 4 months ago by starlight

I expect to not see my relay listed as FallbackDir. Was removed two months ago prior to 0.3.5 going stable.

https://metrics.torproject.org/rs.html#details/4F0DB7E687FC7C0AE55C8F243DA8B0EB27FBF1F2

comment:3 Changed 4 months ago by teor

I can confirm that 4F0DB7E687FC7C0AE55C8F243DA8B0EB27FBF1F2 is not a FallbackDir in any supported Tor branch.

Please update the fallback directories in Relay Search from the tor master branch src/app/config/fallback_dirs.inc

If Relay Search is using Stem's list, this ticket could be a duplicate of #29877.

comment:4 Changed 4 months ago by irl

Owner: changed from metrics-team to irl
Status: newaccepted

comment:5 Changed 4 months ago by irl

Cc: metrics-team added
Priority: MediumImmediate
Status: acceptedneeds_review

Please review and merge the fallback dir update.

https://gitweb.torproject.org/user/irl/metrics-web.git/commit/?h=task/29869&id=89b0b901a52649173085254d576e2fc8f530725f

Sorry it took me so long to get to this.

comment:6 Changed 4 months ago by karsten

Resolution: fixed
Status: needs_reviewclosed

Merged and deployed. Thanks! Closing.

Note: See TracTickets for help on using tickets.