Opened 7 months ago

Closed 7 months ago

#29950 closed defect (fixed)

Error when using runc dev version

Reported by: boklm Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201903R, tbb-rbm
Cc: sisbell Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

It seems that with some versions of runc, the output of runc --version is something like spec: 1.0.1-dev. In this case we incorrectly detect the spec version, because of the -dev, causing an error similar to #23812.

Child Tickets

Change History (4)

comment:1 Changed 7 months ago by boklm

Cc: sisbell added
Keywords: TorBrowserTeam201903R added; TorBrowserTeam201903 removed
Status: newneeds_review

comment:2 Changed 7 months ago by gk

Status: needs_reviewneeds_information

Any reason we use a capturing group in the regex if we aren't actually using the captured item? Seems to me a non-capturing group would do it as well here?

comment:3 in reply to:  2 Changed 7 months ago by boklm

Status: needs_informationneeds_review

Replying to gk:

Any reason we use a capturing group in the regex if we aren't actually using the captured item? Seems to me a non-capturing group would do it as well here?

Yes, a non-capturing group would work. I changed that in branch bug_29950_v2:
https://gitweb.torproject.org/user/boklm/tor-browser-build.git/commit/?h=bug_29950_v2&id=32a4f009d706b9e651071b1b3d361891408eb3aa

comment:4 Changed 7 months ago by gk

Resolution: fixed
Status: needs_reviewclosed

Looks good. Merged to master (commit 32a4f009d706b9e651071b1b3d361891408eb3aa).

Note: See TracTickets for help on using tickets.