Opened 7 months ago

Closed 6 months ago

#29966 closed defect (fixed)

Building container images fails because Wheezy moved to archive.debian.org

Reported by: JeremyRand Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201904R, tbb-rbm
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Trying to run "make nightly-linux-x86_64" in the "tor-browser-build" repo fails with errors relating to 404 HTTP status codes on deb.debian.org. (If you've already built Tor Browser before the move, then reproducing this error probably requires that you make a change to a project's apt-get dependencies so that rbm tries to build a new container image, or else deleting a container image so that rbm needs to build it again.) This happens because Wheezy was recently moved to archive.debian.org.

Child Tickets

Change History (4)

comment:1 Changed 7 months ago by JeremyRand

Possible fix at https://notabug.org/JeremyRand/tor-browser-build/src/wheezy-archive (Git commit hash 9907a1f470cf226285f09ba2911a9a45abbee663 ). I'm now trying to build it with the fix applied; it looks like it's working but I'll reserve judgement until the build finishes.

comment:2 Changed 7 months ago by JeremyRand

Status: newneeds_review

Possible fix at ​https://notabug.org/JeremyRand/tor-browser-build/src/wheezy-archive (Git commit hash 9907a1f470cf226285f09ba2911a9a45abbee663 ). I'm now trying to build it with the fix applied; it looks like it's working but I'll reserve judgement until the build finishes.

Definitely looks like this fixes the issue. (I couldn't finish the build due to unrelated issue #29971, but the container images build without errors now, which is better than the status quo.)

comment:3 Changed 7 months ago by gk

Keywords: TorBrowserTeam201904R tbb-rbm added

comment:4 in reply to:  1 Changed 6 months ago by boklm

Resolution: fixed
Status: needs_reviewclosed

Replying to JeremyRand:

Possible fix at https://notabug.org/JeremyRand/tor-browser-build/src/wheezy-archive (Git commit hash 9907a1f470cf226285f09ba2911a9a45abbee663 ). I'm now trying to build it with the fix applied; it looks like it's working but I'll reserve judgement until the build finishes.

This looks good to me. I merged it to master with commit d8f156e110afe00e0b366cff8ff0e0c53b4a58c9. Thanks!

Note: See TracTickets for help on using tickets.