Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#30035 closed defect (worksforme)

unexpected exit on startup

Reported by: TDionysus Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Major Keywords: tbb-crash
Cc: mcs, brade Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I have just gotten an apple computer, and have never owned one before. when i downloaded and ran tor early yesterday i had no issues. when i open in yesterday night and now around midnight here it says upon loading that it has unexpectedly exited. I have re downloaded and its the newest on the main download page. the logs show nothing and im highly confused as this had never happened on any of my other computers.

Child Tickets

Attachments (1)

rep1.png (1.2 MB) - added by TDionysus 3 months ago.

Download all attachments as: .zip

Change History (10)

Changed 3 months ago by TDionysus

Attachment: rep1.png added

comment:1 Changed 3 months ago by teor

Component: - Select a componentApplications/Tor Browser
Owner: set to tbb-team
Version: Tor: unspecified

Are you using an admin account on macOS?
Are you using an account with parental controls active?

comment:2 Changed 3 months ago by gk

Cc: mcs/brade added
Keywords: tbb-crash added; unexpected exit removed
Status: newneeds_information

mcs/brade: What exactly where the correct incantations for getting info from the command-line on macOS?

comment:3 Changed 3 months ago by gk

Cc: mcs brade added; mcs/brade removed

comment:4 in reply to:  2 ; Changed 3 months ago by mcs

Replying to gk:

mcs/brade: What exactly where the correct incantations for getting info from the command-line on macOS?

The first thing I would check is whether any copies of tor.real (the Tor daemon that is part of Tor Browser) are still running in the background. To do that:

  • Open a command shell by starting the Terminal application (press Cmd+Space and then type Terminal followed by Return, or look in /Applications/Utilities for Terminal and open it).
  • Within the command shell, type ps -A | grep tor.real and see if anything is found.
  • If one or more tor.real processes are found, terminate all of them by typing killall tor.real and then try opening Tor Browser again.

Assuming the above does not fix the problem, you can see tor messages from the command line by opening a command shell (see above) and then starting Tor Browser's firefox process from the command shell. For example, if you have placed Tor Browser in a folder on your desktop named TB, you would type the following command to start the browser (and then look at what messages are output): ~/Desktop/TB/Tor\ Browser.app/Contents/MacOS/firefox

comment:5 in reply to:  4 ; Changed 3 months ago by TDionysus

Replying to mcs:

Replying to gk:

mcs/brade: What exactly where the correct incantations for getting info from the command-line on macOS?

The first thing I would check is whether any copies of tor.real (the Tor daemon that is part of Tor Browser) are still running in the background. To do that:

  • Open a command shell by starting the Terminal application (press Cmd+Space and then type Terminal followed by Return, or look in /Applications/Utilities for Terminal and open it).
  • Within the command shell, type ps -A | grep tor.real and see if anything is found.
  • If one or more tor.real processes are found, terminate all of them by typing killall tor.real and then try opening Tor Browser again.

Assuming the above does not fix the problem, you can see tor messages from the command line by opening a command shell (see above) and then starting Tor Browser's firefox process from the command shell. For example, if you have placed Tor Browser in a folder on your desktop named TB, you would type the following command to start the browser (and then look at what messages are output): ~/Desktop/TB/Tor\ Browser.app/Contents/MacOS/firefox

ty this worked.

comment:6 in reply to:  5 Changed 3 months ago by gk

Resolution: worksforme
Status: needs_informationclosed

Replying to TDionysus:

Replying to mcs:

Replying to gk:

mcs/brade: What exactly where the correct incantations for getting info from the command-line on macOS?

The first thing I would check is whether any copies of tor.real (the Tor daemon that is part of Tor Browser) are still running in the background. To do that:

  • Open a command shell by starting the Terminal application (press Cmd+Space and then type Terminal followed by Return, or look in /Applications/Utilities for Terminal and open it).
  • Within the command shell, type ps -A | grep tor.real and see if anything is found.
  • If one or more tor.real processes are found, terminate all of them by typing killall tor.real and then try opening Tor Browser again.

Assuming the above does not fix the problem, you can see tor messages from the command line by opening a command shell (see above) and then starting Tor Browser's firefox process from the command shell. For example, if you have placed Tor Browser in a folder on your desktop named TB, you would type the following command to start the browser (and then look at what messages are output): ~/Desktop/TB/Tor\ Browser.app/Contents/MacOS/firefox

ty this worked.

Good to hear! What was the problem? tor still running in the background?

comment:7 in reply to:  4 Changed 3 months ago by arma

Replying to mcs:

The first thing I would check is whether any copies of tor.real (the Tor daemon that is part of Tor Browser) are still running in the background.

Is this something Tor Browser, or the startup script, can do automatically for the user? It seems bad to leave this trap lying around for users, especially if we don't know what fraction of users are hitting the problem (and abandoning Tor Browser because of it).

comment:8 Changed 3 months ago by arma

We just had another user on irc asking this same question:

<seanmcc554> hey everyone, for some reason my tor browser application won't start, it wont properly restart
> what version of tor browser? what OS? what goes wrong?
<seanmcc554> @arma, the screen says "tor unexpectedly exited" and it wants me to restart tor... I restart tor and the same page pops up
<seanmcc554> and im also on the Mojave OS (Mac)
<seanmcc554>  the screen says "tor unexpectedly exited" and it wants me to restart tor... I restart tor and the same page pops up

I assume if somebody goes to the effort of getting to irc, there are hundreds more who just give up before that step. So this seems like a potentially big bug.

comment:9 Changed 3 months ago by mcs

TDionysus, have you seen this problem again since you made your original report? Our Tor Browser development team would like to learn how to reproduce this problem since it seems like other macOS users are encountering it as well.

Note: See TracTickets for help on using tickets.