Opened 7 months ago

Closed 7 months ago

#30038 closed defect (fixed)

libgtk2.0-dev is not needed for WebRTC building (anymore)

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: TorBrowserTeam201904R, GeorgKoppen201904, tbb-rbm
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

While looking over the F-Droid integration I saw they were wondering about the libgtk2.0-dev requirement. Upon poking a bit more it seems we don't need that at least for WebRTC anymore. I'll attach a patch shortly.

Child Tickets

Change History (2)

comment:1 Changed 7 months ago by gk

Keywords: TorBrowserTeam201904R added; TorBrowserTeam201904 removed
Status: newneeds_review

bug_30038 (https://gitweb.torproject.org/user/gk/tor-browser-build.git/commit/?h=bug_30038&id=f266df2fedf0ab596aaed55b3ee835dcfd55f88b) in my public tor-browser-build repo has a fix for review. It would be neat, if we had a slightly more predictable way of just building with the absolutely necessary dependencies than randomly, manually inspecting the build deps and cleaning them up.

comment:2 Changed 7 months ago by boklm

Resolution: fixed
Status: needs_reviewclosed

This looks good to me. I merged it to master as commit f266df2fedf0ab596aaed55b3ee835dcfd55f88b.

Note: See TracTickets for help on using tickets.