Opened 4 months ago

Closed 4 months ago

#30068 closed defect (duplicate)

Canvas permission popup steals focus from textfield

Reported by: jikin Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: antonela Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When navigating to a site (for example a login form), I start filling in the form, and suddenly the popup appears and my keystrokes are not registered anymore.

Can we maybe just set privacy.resistFingerprinting.autoDeclineNoUserInputCanvasPrompts to true?

There's many threads on forums, reddit & stack exchange of users being annoyed by the popup.

Child Tickets

Change History (1)

comment:1 Changed 4 months ago by gk

Component: UXApplications/Tor Browser
Owner: changed from antonela to tbb-team
Resolution: duplicate
Status: newclosed

Duplicate of #29028. We've tested the fix a bit in our alpha series. It seems it works as expected, thus we either backport the preference flipping for the next stable or you'll get it by us releasing Tor Browser 8.5 (whatever comes first).

Note: See TracTickets for help on using tickets.