Opened 6 weeks ago

Closed 2 weeks ago

#30136 closed defect (fixed)

Decide whether to use "Tor Browser" or "Tor Browser for Android" for mobile stable

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile, tbb-parity, tbb-8.5-must, GeorgKoppen201904, TorBrowserTeam201905R
Cc: steph, sysrqb, emmapeel Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

In #28622 the question came up whether we should use "Tor Browser" or "Tor Browser for Android" for mobile. I think the former as Android is yet another platform besides Windows, macOS, and Linux. We only have one browser that serves all the platforms.

Child Tickets

Change History (12)

comment:1 Changed 5 weeks ago by gk

Cc: emmapeel added

Adding emmapeel as this might affect translations/translators.

comment:2 Changed 5 weeks ago by steph

I think "Tor Browser" makes sense, matching with other platforms. We will still mention for Android where appropriate in promotions.

comment:3 in reply to:  2 Changed 4 weeks ago by gk

Replying to steph:

I think "Tor Browser" makes sense, matching with other platforms. We will still mention for Android where appropriate in promotions.

Makes sense, thanks.

comment:4 Changed 4 weeks ago by gk

Keywords: GeorgKoppen201904 added

comment:5 Changed 4 weeks ago by gk

Keywords: TorBrowserTeam201904R added; TorBrowserTeam201904 removed
Status: newneeds_review

comment:6 Changed 4 weeks ago by cypherpunks

"Tor Browser" is valid for all other platform. make it "Tor Browser" on mobile too

comment:7 Changed 3 weeks ago by sysrqb

lgtm. I'll build them tomorrow.

comment:8 Changed 3 weeks ago by gk

Keywords: TorBrowserTeam201905R added; TorBrowserTeam201904R removed

No April anymore, moving review tickets to May.

comment:9 Changed 3 weeks ago by sysrqb

These look good, but I noticed another bug we should fix (probably a fixup for #28622). When I built with official branding, I see the about:firefox favicon is using the alpha icon (blue-ish), instead of the official icon (purple-ish). I'm rebuilding now to confirm this wasn't caused by something else.

comment:10 in reply to:  9 ; Changed 3 weeks ago by gk

Replying to sysrqb:

These look good, but I noticed another bug we should fix (probably a fixup for #28622). When I built with official branding, I see the about:firefox favicon is using the alpha icon (blue-ish), instead of the official icon (purple-ish). I'm rebuilding now to confirm this wasn't caused by something else.

Hm, how did the rebuild go? Do you still see the issue? If so, could you attach a screenshot showing the problem? I double-checked the assets in mobile/branding/official (which should get used by the stable build) and did not find any alpha related icon.

comment:11 in reply to:  10 Changed 2 weeks ago by sysrqb

Status: needs_reviewmerge_ready

Replying to gk:

Replying to sysrqb:

These look good, but I noticed another bug we should fix (probably a fixup for #28622). When I built with official branding, I see the about:firefox favicon is using the alpha icon (blue-ish), instead of the official icon (purple-ish). I'm rebuilding now to confirm this wasn't caused by something else.

Hm, how did the rebuild go? Do you still see the issue? If so, could you attach a screenshot showing the problem? I double-checked the assets in mobile/branding/official (which should get used by the stable build) and did not find any alpha related icon.

Whoops! I forgot to update this. The rebuild was good, I'm guessing this was caused by some artifact. I think this is ready.

comment:12 Changed 2 weeks ago by gk

Resolution: fixed
Status: merge_readyclosed

Fixed with commit 3d5e5cc086f443c5ab5a0125a174d3e5f50181a2 on tor-browser-60.6.1esr-8.5-1, thanks.

Note: See TracTickets for help on using tickets.