Opened 8 months ago

#30141 new task

Double-check exoplayer library for vulnerabilities

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-mobile
Cc: Actual Points:
Parent ID: #30139 Points:
Reviewer: Sponsor:

Description

The exoplayer library currently used (r2.4.0) is rather old (latest stable is r2.9.6) and Mozilla has already found some defects with the help of coverity that should get fixed (see: https://bugzilla.mozilla.org/show_bug.cgi?id=1371247). There are potential security bugs that got fixed between r2.4.0 and r2.9.6 that we should pick up as well.

Child Tickets

Change History (0)

Note: See TracTickets for help on using tickets.