Opened 9 months ago

Closed 9 months ago

#30195 closed enhancement (duplicate)

Resize window to default automatically

Reported by: cypherpunks Owned by: tbb-team
Priority: High Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There are many times when I accidentally resize my browser window. There needs to be an option or perhaps when using Safest settings to automatically resize the window back to the original dimensions when it has been changed by the user.

Child Tickets

Change History (6)

comment:1 Changed 9 months ago by cypherpunks

The best way could be when using Safest settings to not allow browser window to change size.

comment:2 Changed 9 months ago by Thorin

If you maximized the browser, just restore it. If you went full screen, just escape or F11 out of it. You will return to the previous size and position.

There is a new feature coming in TB version 9 (the one based on Firefox 68) that will mitigate manually resizing to a large degree, called letterboxing - it limits the viewport in the inner window, rather than relying on the browser and vrious chrome elements.

Until then, when this happens, open a new window and close the existing one (and you will lose your tabs, sorry). NEW windows will open at the 200x100 pixel inner window sizes

comment:3 Changed 9 months ago by cypherpunks

Letterboxing is good but not a perfect solution to this. Not allowing the user to resize at all when using Safest settings is the more secure and foolproof solution.

comment:4 Changed 9 months ago by Thorin

No one is sure yet what the final form will take. It may be that sizing on new windows is replaced by letterboxing, or it may be that it is used in conjunction. And the letterboxing step sizes (which may be a sliding scale) haven't been decided. Until tests are done etc, it's not even known if this ticket will even be an issue (don't get me wrong: letterboxing will encourage more entropy, and having a set startup size is beneficial, as is sticking to it when you can).

Right now the letterboxing is using a hardcoded 200x100 steps, so your situation in future is actually already fixed: e.g

  • you open at 1000x1000 pixels
  • you accidentally drag the window slightly bigger (say 1000x1034)
  • your viewport stays at 1000x1000. You were protected the whole time

Disabling the browser chrome is most likely going to be a wontfix - I can't speak for gk et al, but it adds complexity that isn't needed, even if it could be done. And users could still maximize or go full screen. Allowing resizing is a usability issue - all these years it's just been a warning not to resize the browser - why would they suddenly lock the size at this stage, esp with letterboxing coming.

That said, after the final form is decided, it would be kind of nice for a preset button that resets a window size - I think there's even another ticket open for that

comment:5 Changed 9 months ago by Thorin

And just to add to that, if the browser was disabled from being resized: that would mean that the sidebar, the toolbar, the menubar, the density, the findbar (and maybe a few others I missed) would also need to be blocked/locked at a set display/size - because they all change your inner window as well. And that's just chrome elements.

comment:6 Changed 9 months ago by mcs

Resolution: duplicate
Status: newclosed

Resolving as a duplicate of #16364. Please follow the discussion there.

Note: See TracTickets for help on using tickets.